Link to home
Create AccountLog in
Avatar of yo_bee
yo_beeFlag for United States of America

asked on

Exchange 2010 Full Access issue

I am in the process of moving over from my dinosaur Exchange 2003 server to Exchange 2010 and one of the things I cam across is the inability to access users mailboxes as I did on 2003. I see that I can grant Full Access to a mailbox and I will be able to then mount it in Outlook, but when I remove it the Mailbox still remains mounted.  The only way I have been able to remove it is to remove the ACL Full Access from that mailbox.  Is this normal behavior?

Also I need to grant a group Full access to all mailboxes.  How can I accomplish that as well.

Thanks
Mike
Avatar of Seth Simmons
Seth Simmons
Flag of United States of America image

in 2010, if you give someone full access to a mailbox, it will appear automatically in outlook
remove it and it goes away automatically; different from 2003
Avatar of yo_bee

ASKER

So how to you give users (Exchange Admins) rights to access the mailbox, but remove it when needed?
Auto-mapping feature is enabled by default. If you want to disable it you can do this on a per mailbox basis. Use the following command...
Add-MailboxPermission -Identity <alias> -User <user1> -AccessRights FullAccess -InheritanceType All -Automapping $false

Open in new window


You can enable full mailbox permissions on the server through active directory
- Open ADUC
- Ensure that View Advanced Features is Enabled
- Find the Exchange Server in ADUC
- Right click, Properties
- Click on the Security Tab
- Advanced Settings
- Change Permissions button
- Click the Add button
- Add the Group or User
- Apply the Full Access (which will apply to all mailboxes on this server)

Any existing mailboxes and new mailboxes created will have the New Group or User with Full Mailbox Permissions applied.

Will.
Avatar of yo_bee

ASKER

@Will is there a PS command that does the same as what you describe in ADUC?
ASKER CERTIFIED SOLUTION
Avatar of Will Szymkowski
Will Szymkowski
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of yo_bee

ASKER

@Will
Does that need the -Automapping $false or is that the same if you used the GUI?
Avatar of yo_bee

ASKER

Thank you for the help.
Avatar of yo_bee

ASKER

@Will
I just had to use the Add-MaiBoxPermission  command to access the account when outside of my profile in Outlook.
Is this normal behavior?