0xc000021a during 2012 R2 DC promotion

Enviroment:
Windows domain running 2008.
One windows server as the current DC and a new workstation that has a Samsung SSD Evo drive present.
Windows Server 2012 R2 installed as a member server.

Goal is to migrate from one server to another and decommission first server. The initial install of Windows Server 2012 R2 completes 100% ok on the replacement and everything replicates ok. All drivers are patched and current on replacement server. I place server in domain and restart multiple times. All is fine so far.

However, once I start the DC promotion portion with the automated wizard and it restarts, I immediately get a stop error of 0XC000021A.

Performing some research I have connected this to the Samsung 850 EVO SSD present in the system. Apparently, it is changing something to the SSD (write caching?) and this setting is toggled once promoted. More info found here: https://social.technet.microsoft.com/Forums/windowsserver/en-US/ebc71806-37ab-49c4-9218-9964b30d958a/0xc000021a-during-server-2012-r2-essentials-setup?forum=winserveressentials&prof=required

The question remains: How can I fix the toggled setting to allow it to boot into windows as a DC without formatting it and starting over using a different SSD?

I know I can use a SSD but I would like it to work with the EVO if possible. Note: This is reproducible on any Samsung EVO SSD of any size.
LVL 1
tadduciAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alessandro ScafariaInfrastructure Premier Field AdministratorCommented:
https://social.technet.microsoft.com/Forums/systemcenter/en-US/81c6d52f-578c-44c8-a6ec-18c03a818295/cant-promote-server-2012-r2-to-domain-controller-get-error-0xc000021a?forum=winserverDS

The SSD is the evildoer.
I will waiting for other Experts opinion, but probably you should start thinking on replacing your HW drive for this scenario.....
0
tadduciAuthor Commented:
I know it is the SSD but if you read the goal above I need to know how I can swap in another SSD by either imaging it or toggling a setting to reenable write cache perhaps.

I am trying to determine why the 850 presents this issue vs. the 840 or another brand does not.
If I absolutely cannot use the 850 how can I use the 840 given the situation I am in now without redoing everything?
0
tadduciAuthor Commented:
Issue solved: Must use a 840 drive. I have determined that you can take the 850 drive, image it to another drive, boot from that new HDD/SSD and everything will work ok.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tadduciAuthor Commented:
I solved issue by the method described.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.