Remote Desktop Resolution on 3840 x 2160 Windows 8.1 Laptop

I just got a new laptop, and when I try to use the Remote Desktop Connection to connect to a computer, the resolution of the remote desktop is extremely small, almost unreadable. My laptop has a resolution of 3840x2160. If I bring the resolution way down on my laptop, the RDP session shows up ok, but that's a total nuisance--I connect to numerous computers through remote desktop every day. If I change the resolution in the RDP settings, the fonts don't appear larger, it just shrinks the overall window size of the RDP session.

Is there a way to increase the size of the remote desktop sessions without having to adjust my monitor resolution every single time?
saturationAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Open RDP, click on More Options (lower left), Display tab, and choose the display resolution you need. This works for me just fine.
McKnifeCommented:
To change the remote font size, you have to change the dpi value. On some OS' however, Microsoft has blocked this. You will read "the display settings can't be changed from a remote session" - for example take server 2008 R2, the most popular terminal server solution... Microsoft simply blew it.
There are people aware of that problem and offer solutions:  http://www.michelstevelmans.com/change-text-size-remote-desktop-session/
KimputerCommented:
In _some_ situations the microsofts own Remote Desktop Connections manager, currently v2.7 (http://www.microsoft.com/en-us/download/details.aspx?id=44989) helps, and otherwise a thirdparty app like mRemoteNG (http://www.mremoteng.org/), try fiddling with the screen size settings, but full screen should do it.
Main problem is that the new mstsc client does support smart sizing, except only the other way around (scaling down instead of up).
Both solutions only solve this problem in some situations (depends on some client factors as well as server factors, like OS etc)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

JohnBusiness Consultant (Owner)Commented:
@saturation  - Try the RDP setting I suggested to see if it works for you. I tried it on Server 2008 and Server 2012 and I could reduce the resolution on both remote sessions. It might work for you.
McKnifeCommented:
@John: he talks about the pixel size of the items he sees. Your setting only influences the resolution.
JohnBusiness Consultant (Owner)Commented:
Once I set the resolution, the size of the items on the screen changes as well. That is why I use it.
McKnifeCommented:
? I wonder why. For me it does not and I have been using it for ages.
JohnBusiness Consultant (Owner)Commented:
I do not know. I use a relatively low resolution host (tiny screen 1366x768) and I can set RDP for 800x600 and it comes out looking like 800x600. I have never tried high resolution so I cannot replicate this issue on my machine.

I know Windows 10 will not handle 800x600 but that is a different issue.
saturationAuthor Commented:
@John Hurst: I tried changing the display size on the RDP connection settings, but that just reduces the window. In fact, reducing that shrinks everything even further.
 
I'm looking at some of the other solutions posted here, but it's not looking to good. I can't believe Microsoft on this one. I bought a new laptop, and now the RDP sessions are so small that they're almost unreadable. I
McKnifeCommented:
"but it's not looking to good" - it works anywhere but on server 2008 R2. There, you'll need the tool that I linked.
saturationAuthor Commented:
@Kimputer and @McKnife--I tried both of these, and they work. mRemoteNG is a little easier to use since I can keep all of the RDP sessions organized easily...I am so glad you guys saved me!  I thought I was going to have to return this laptop to Dell.

I hope MS figures out a way to resolve this. Unfortunately, not even their own RDP Manager application resolves the issue. Way to go, Microsoft!

Thanks again for the replies here!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.