Link to home
Create AccountLog in
Avatar of Mark Galvin
Mark GalvinFlag for United Kingdom of Great Britain and Northern Ireland

asked on

XenApp 6.5 allowing more than one instances of app

Client has a number of Published Apps in their XenApp 6.5 farm. One of those is a Desktop that is used by IT Admins. The app is set so that only one instance of the app runs per user:
User generated image
There is one Admin that keeps reporting the Admin Desktop getting stuck and asking IT Support to reset their session. This morning, this admin reported the same and on checking his sessions we see 6. 5 from one client device and 1 from another. All from Surface tablets:
User generated image
Any way to prevent this?

Thanks
Mark/
Avatar of Will Szymkowski
Will Szymkowski
Flag of Canada image

This is a known issue when launching Publish Desktops with the Allow Limit Set. See the link below for additional details on how to connect this issue.

http://support.citrix.com/article/CTX118656

Will.
Avatar of Mark Galvin

ASKER

Hi

I will check and see if that helps. The Citrix page states:
Problem Cause
Users rapidly clicking published application icons can initiate multiple sessions prior to the application instance counter getting updated.

However looking at the 2nd April in the list of sessions there is about 3 hours between initiation times.
As as per will its known issue, you can set session timeout to logoff the disconnected session.
They aren't disconnected. They are all reported as being ACTIVE.
ASKER CERTIFIED SOLUTION
Avatar of Sekar Chinnakannu
Sekar Chinnakannu
Flag of Singapore image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I havent installed the roll up pack.

I have scheduled down time on their system tonight so will install and see how it goes.

Thanks
Mark/
OK. Roll Up Pack 5 installed and so far no multiple sessions. However, users are having issues when launching published desktops. Some users get
User generated imageAnd some get:
User generated imageFor the second error I have tried Solution 1 from https://support.citrix.com/article/CTX130480 but that hasnt helped.

Any clue?
Thanks
Mark
Can you provide event log details and same time make sure are up to date in windows updates. Also refer this steps http://support.citrix.com/article/CTX368624
Hi know what the issue is.

Couple of weeks back the server that was acting as the Citrix License server died. The role was moved to another server, licenses returned via MyCitrix and reallocated to new server. License server details were changed within the XenApp Computer policy (Citrix not GPO) as well as through the XenApp Server Role Manager.

Now these are appearing in the System Log:
User generated imageand
User generated imageDC05 is the old License server.

When I check the load on the server I get:
User generated imageServer CXA01 is still in the grace period (519 hours left). Servers CXA02 & CXA03 arent and no longer accepting connections.

I have tried http://support.citrix.com/article/CTX126713?_ga=1.108512839.476284222.1420626502 but didnt help.

And Ideas?

Thanks
Mark/
I have removed the license server settings from the Citrix policy as I thought that as its set in the XenApp Server Role Manager too there may have been a conflict etc. I made that change 24 hours ago and have rebooted all three servers multiple times but still the servers are not picking up the change of name in the license server.
GRRRRR

Found it!!

Following this link https://nialljen.wordpress.com/2013/11/05/configuring-licensing-in-a-xenapp-6-5-environment/

I opened the XenApp Servers GPO from one of the XenApp servers and saw that the Citrix Policy set there was still referring to the old server!! Changed it there, ran a GPUPDATE /FORCE on one of the downed servers and now working fine. Load is correct and it is accepting connections!!

I wonder if its documented how the policy priorities are as the Citrix GPO (from a XenApp server) is the one that takes priority! I need to remove the others and document for the client!!

Thanks
Mark/