Have an old cisco 800 Series router with 4 switchports and one Wan, can I route between VLANS on the switchports?

I've set up two of the LAN switchports to host two VLANs but I cannot get hosts on those respective ports to communicate with each other no matter.  Didn't know if this was a limitation of the router itself or what.  I can get this running on a switch with no problem, but not this device.  Any ideas?  Thanks.
LVL 1
LB1234Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
That should not be limitation of router. I worked with 800 series and I did not have such issue.
Can you paste configuration?
0
LB1234Author Commented:
Current configuration : 4063 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!

ip cef
!
!
ip dhcp excluded-address 10.10.10.1
!
!
no ip domain lookup
ip domain name yourdomain.com
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
! 
!
archive
 log config
  hidekeys

interface FastEthernet0
 switchport access vlan 10
!
interface FastEthernet1
 switchport access vlan 20
!
interface FastEthernet2
 switchport access vlan 30
!
interface FastEthernet3
!
interface FastEthernet4
 no ip address
 duplex auto
 speed auto
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 no ip address
 ip tcp adjust-mss 1452
interface Vlan10
 ip address 10.1.50.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
!
interface Vlan30
 ip address 192.168.30.1 255.255.255.0
!
ip forward-protocol nd
no ip route static inter-vrf
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
no cdp run

line con 0
 exec-timeout 0 0
 logging synchronous
 no modem enable
 speed 115200
line aux 0
line vty 0 4
 access-class 23 in
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
 transport input telnet ssh
!
scheduler max-task-time 5000
end

THanks.

Open in new window

0
JustInCaseCommented:
Configuration seems to be OK.
ip routing is missing - but I think that is default on this routers, so it will not be shown in running config. You can check is ip routing  command present on router issuing #show running-config all.

Did you double check ip addresses and default gateway on hosts?
Can you ping your default gateway address from hosts?
0
JustInCaseCommented:
I entered network parts of your config to Cisco 881 and intervlan traffic is OK.

In my case I had problem with one host - windows 7 - network location was set to public, and even from router I could not ping that host, although that host could ping router and all other hosts (maybe that is problem in your case).
When firewall is turned off on that host I could ping it, and everything worked fine, so ...

Double check ip addresses and default gateway on hosts.
Try to ping your default gateway address from hosts and ping hosts from router to check is ping from router to hosts is OK.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.