Discovery not running in XA6.5

Hi, I am facing issues while running discovery in XA 6.5 farm. I have two ZDC and two session host servers. Able to make odbc connection from ZDC to database server. All servers are running on Citrix servers but discovery is failing stating to check if MSCOM service is running or to make sure that citrix server is running. Nothing has been changed on ZDC's or Database servers. Have created new dsn file, recreated LHC but the problem is still there.

Any help would be highly appreciated.
Horus IDFSystem AdminAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sekar ChinnakannuStaff EngineerCommented:
Can you check the event log and update the same, Also make sure both DC's are working fine and all the services are running.
- did you installed any updates from Microsoft or citrix? if so try to remove and check
- Change services to run using local service
0
Tony JohncockLead Technical ArchitectCommented:
Could be a number of things.

Some of them to check are here: http://support.citrix.com/article/CTX126977

Check the Citrix services are started.

As Sekar said, check if any hotfixes went on over the last few nights.

Make sure ports aren't being blocked on the servers etc.

Make sure the account used to access the DS isn't locked out/password has been changed. Might be worthwhile updating the password and then reconfiguring the XA servers to use it:

dsmaint config /user:domain\tony /pwd:Password01
/dsn:"C:\Program Files (x86)\Citrix\Independent Management Architecture\mf20.dsn"

Obviously change the user and password for your correct values.
0
Horus IDFSystem AdminAuthor Commented:
Thanks for answering. I am quite sure that nothing is changed. No windows or citrix hotfix are deployed. Infact I have a new server and made it zdc but while running discovery it is giving the same error. I already ran dsmaint command to update the password. Service account is also not locked.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Tony JohncockLead Technical ArchitectCommented:
And all Citrix services are running that should be? Including MFCOM?
0
Sekar ChinnakannuStaff EngineerCommented:
If possible change services to run using local system and check
0
Horus IDFSystem AdminAuthor Commented:
All citrix services are running. Moreover I have changed them from Network to local but problem is still there.
0
Tony JohncockLead Technical ArchitectCommented:
Did you go through the Citrix article I linked to above?

What gets posted into the event logs of the servers?
0
Sekar ChinnakannuStaff EngineerCommented:
can you check the event log and post the event details also make sure with server load on data collector.
0
Horus IDFSystem AdminAuthor Commented:
I am not getting any error related to discovery failure. I get only one error few times in a day "Citrix XenApp is unable to retrieve the product version. Check to see if the Citrix Independent Management Architecture service is running without errors.  Citrix XenApp cannot request licenses until it can obtain the product version--no client devices can connect. If necessary, set the product version in the Citrix Group Policy" because I am using evaluation version of licences.

@Tony - Yes I went through that article and followed it.
0
Sekar ChinnakannuStaff EngineerCommented:
When you face the problem how about the server load on data collecters? Did you checked if not next time check the same and event logs too
0
Tony JohncockLead Technical ArchitectCommented:
Agreed - you say no error related to discovery but it should be posting _something_ when you try to run one.

Please try to rerun and look at the event logs.
0
Tony JohncockLead Technical ArchitectCommented:
One other thing...are you sure you are logged on as a Citrix administrator? Have you tried logging on as different users (local admin, for example) before running the console?
0
Horus IDFSystem AdminAuthor Commented:
Yes I am..It was working fine couple of days earlier from my account. I have one more account and I am getting same error with it also.
0
Tony JohncockLead Technical ArchitectCommented:
Something must have changed.

Most likely is going to be a password change.

Have any passwords in use possibly changed since the failure? Your admin account(s), and service accounts, and database/datastore accounts?
0
Horus IDFSystem AdminAuthor Commented:
We used service account to add it to Farm and I am sure it's password has never been changed. Yes admin accounts passwords must have been changed in between. I ran dsmaint with the same service account whose password was never changed and we used the same account to set up this farm.
0
Tony JohncockLead Technical ArchitectCommented:
Also worth looking at the diagnostic toolkit http://support.citrix.com/article/CTX135075
0
Horus IDFSystem AdminAuthor Commented:
Problem got solved. We had one stale entry in datastore which was pointing to a server which was no longer a part of farm. We identified it after running dscheck and removed it after taking backup of datastore through dscheck only. Discovery started running fine after that.

Thank you Tony and Sekar for all your help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sekar ChinnakannuStaff EngineerCommented:
Cool, Glad that you able fix the problem.
0
Horus IDFSystem AdminAuthor Commented:
None of the answers posted by participants helped me to sort it out. I mentioned what I did to fix it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.