set up ntpd in anacron in Redhat 6.4

I want to have my server update its time on a daily basis. The server runs 24/7 and is not rebooted.

currently i have ntpd and ntpdate installed, but not started
#chkconfig  lists them both off

the /etc/crontab is empty
there are files in /etc/cron.daily but nothing for ntpd or ntpdate

i'm thinking i need to
#service nptd start
#chkconfig ntpd on

What do I need to have it run daily?
Once it starts, can I force it to update? Right now the server is 2 minutes slow.
LVL 1
penguins_ruleAsked:
Who is Participating?
 
savoneCommented:
ntpd is a daemon, meaning it runs constantly in the background and keeps the time from drifting.  This is your best option.

Configure ntpd and then start the service and enable it on boot:

service ntpd start
chkconfig ntpd on

That's it.  You do not need to run it in a cron job, it will take care of time for you.

I believe the default ntpd configuration looks at the redhat ntp pool, which is fine.  You shouldn't need to change the configuration unless you want to do something special.
0
 
penguins_ruleAuthor Commented:
Without booting the system after issuing these two commands, will it start updating the clock now?
0
 
savoneCommented:
Yes
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.