RDP 2008 - printer redirected, but won't print

I have a 2008 server with a terminal on it. When connected, the client printers are redirected, but when I try to print it doesn't work.

I tried printing from 2012 and 2003 server, and it worked flawlessly.

Any ideas?

(EasyPrint is turned on, that is not configured in GPO.)
mrmutAsked:
Who is Participating?
 
mrmutAuthor Commented:
Thanks for reply; but I managed to fix this.

Apparently, as TS is on a DC, spooler directory is permission limited. In the end I found KB article describing this, which fixed the issue.

support.microsoft.com/kb/968605/EN-US

As for EasyPrint - I feel it is something like early Plug N Play (pray). It oft doesn't work.
0
 
Hypercat (Deb)Commented:
In my experience, Easyprint doesn't work for a lot of lower-end printers.  Depending on the model of the printer(s), you may need to install drivers on the 2008 server, and if there aren't any compatible drivers, you may be out of luck.  What models of printers are on the client machines?
0
 
mrmutAuthor Commented:
No other solutions worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.