RDP 2008 - terminal garbled when using 15bit colors

Did anyone seen a problem where terminal contents are mainly garbled when color number is set to 15bit? When I set 16bit, it is fine, but taxing to internet connection.

garble.png
I even have the same problem connecting to 2003 server with 256 colors, which works flawlessly otherwise.

Thanks!
mrmutAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

skijCommented:
On the "Experience" tab try changing the connection speed setting, and try changing the values of the checked boxes.
0
mrmutAuthor Commented:
I did, and that does fix the issue, but why doesn't it work on 15bit setting?

This is not normal, and on servers limited to 256 colors (2003) can't obviously be changed.
0
skijCommented:
It has to do with the way that Windows utilizes font smoothing.  The intent it to make the edges look soft but when you are working with a limited number of colors, it distorts the edges.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

NVITEnd-user supportCommented:
Not at a station right now to confirm but... I recall seeing some sort of  font ClearType/smoothing/enhancement setting somewhere. Maybe try turning that off.

Also, I think you already tried this as mentioned by skij, but make sure the client has updated Remote Desktop Client that provides support for font smoothing: http://blogs.technet.com/b/askperf/archive/2008/07/01/terminal-services-and-cleartype.aspx
0
skijCommented:
The "Font smoothing" checkbox is on the "Experience" tab when you connect.
0
mrmutAuthor Commented:
OK, I tried this, and combinations, with no effect.

I also tried connecting thru terminals, but the same happened. The graphics are still garbled.

Any other idea or anything else to try?
0
mrmutAuthor Commented:
Update: I also tried disabling clear type on server (Do not allow Font Smoothing GPO).
0
skijCommented:
Try this:

Step 1: In the General tab, select "Save As..." and and create a .rdp file.

Step 2: Open the .rdp file in a text editor like Notepad.

Step 3: Find the line that reads something like:
session bpp:i:15

Change that line to this:
session bpp:i:8

Step 4: Save the .rdp file

Step 5: Open the .rdp file either by clicking on it or by opening it in the Remote Desktop Connection client.
0
mrmutAuthor Commented:
Wow. I didn't know this was possible.

I tried it, and graphics are garbled all the same.
0
skijCommented:
Try changing all these values.  If they are already set to 0 change the value to 1 and if they are already set to 1 change the value to 0:

videoplaybackmode:i:0
allow font smoothing:i:0
disable menu anims:i:1
disable themes:i:1
bitmapcachepersistenable:i:0
0
mrmutAuthor Commented:
Tried it, still the same.

garble2.png
0
skijCommented:
I do not have any additional ideas.  You may have to use 16bit.  Good luck!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mrmutAuthor Commented:
Yeah... I came to thins conclusion too. :-(
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.