Avatar of Link
Flag for United States of America asked on

How to Telnet to Win7

I am studying for CCNA-security. I have a private test network that  includes a Virtual Box with Win-XP, Win7 and Win2008 VM’s all in different subnets and with  all firewalls disabled. This is a test network and don’t need to care about security.  No connection to internet and the VM’s are just for supplying  various protocols so I can test a Cisco ASA firewall.
To begin with I want each machine to be able to FTP, Telnet, TFTP, HTTP, HTTPs, to each other.

Today’s  Problem – WinXP machine  can’t  Telnet to Win7 machine.  XP command prompt :
“Connecting to…Could not open connection to the host, on port 23: connect failed.”

-      Both machines can ping each other
-      Both machines can telnet into Cisco Routers (so telnet client is working at least)
-      Win7 can telnet to WinXP no problem.
-      Win7 has Telnet Server and Telnet Client Enabled (seen in “Control Panel- Programs – Turn Features on/off – …..Telnet Server = on; Telnet Client= on
-      Win7 Computer name: Miles-PC
-      Win 7 Workgroup = WORKGROUP
-      User Accounts –
Miles: Administrator / Password protected
tim: Standard User / Password Protected
-      Firewall = OFF (for Domain, Private, Public) as seen in Control Panel – Firewall - Advanced
-      Even the win7 default gateway (cisco router) can’t telnet directly to the Win7 PC, But here at least I am prompted for a username/password. I’ve tried using as usernames: Miles-PC\Miles; Miles-PC\tim …..but each time it says “Login failure: unknown username or bad password”.
-      Firewall disabled but even still the Control Panel – Security- Firewall - “Allow programs to communicate through Windows Firewall” has Telnet selected for private/work networks. Not sure if this is even applicable if Firewall is off anyway.

This seems impossible… What am I doing wrong? Will be very grateful for anyone who can solve this.
Windows 7SSH / Telnet SoftwareSoftware Firewalls

Avatar of undefined
Last Comment

8/22/2022 - Mon
Miguel Angel Perez Muñoz

Could you try telnet from your Win7 to Win7 computer? This ensures your Telnet client is running fine

On the Windows 7 computer rom a cmd prompt run netstat -an which will show what ports are open

Seen where just disabling the firewall in windows 7 does not truly disable  it

enable the firewall and in the inbound rules allow port 23

Did you add the telnet client and server in windows 7 features by default it is not installed.  Go to programs and features and add the telnet server and client (if you want to originate from that system) once added you can set the telnet server service to automatic.  If you want  to re-enable the fw then you will have to allow the port in and out in the fw rules.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck

@Miguel  - As I stated above, Win 7 client works .....(- Win7 can telnet to WinXP no problem.)

@trgrassijr - With Firewall enabled I go to "Allow programs to communicate through Windows Firewall" and see that "Telnet" is selected for "allowed programs through firewall". In any event going the inbound rules with firewall enabled, I see "Telnet Server" enabled with Allow action. I'm assuming this is port 23. Still doesn't work.
@tmoore1962 - As I stated in the initial description telnet client and server were enabled .....(- Win7 has Telnet Server and Telnet Client Enabled)

All, I have tried so many combinations of things and nothing seems to work. I even restored back to an earlier time. It seems strange that yesterday I could at least get the Win7 machine to prompt for a username/password. I have to conclude there is no solution to this and telnet-server simply doesn't work for Win7 VM.

View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.

Try port 80.

Thanks so much....yes I had to set  the Telnet service to automatic for it actually run upon start up, then I can see port 23 in LISTENING state with netstat -an. One other additional step is I needed to create a Standard user "Fred" and then go to Admin Tools-Computer Management-Local Users and Groups-Groups-Telnet and put the standard user into the Telnet group
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.