Attempting to backup all GPO's fails on both Domain Controllers

error: the specified server cannot perform the requested operation

This happens on both of my domain controllers. If there is any way that I can get this resolved that would be fantastic. We have oodles of GPO's in our current domain (single label) that I want to backup and restore in our new TLD compliant domain. I know I could recreate them all, but this seems like an simple issue. After furiously googling, still haven't gotten anywhere with it. I have tried using the powershell commands and the GUI with no luck. Whether attempting to backup one GPO or all of them, never a success.

I am using Server 2012 domain controllers, domain and forest functional level of server 2012screenshot of error
aackarAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Miguel Angel Perez MuñozCommented:
What method are you using to do backup?
Could you try: Backup-GPO -All -path C:\somewhere\ -domain yourdomain.com -server yourdomainserver.yourdomain.com
Will SzymkowskiSenior Solution ArchitectCommented:
Can't say that i have seen that before. Does your account have the proper permissions? Can you backup any of the GPO's successfully?

Have you checked the event viewer on the DC's to see if they are generating any error messages?

Will.
aackarAuthor Commented:
I had tried powershell previously, just with less switches. Attached is the output of the command

GPOBackup2.PNG
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

aackarAuthor Commented:
The account definitely has the needed permissions. I will triple check the logs just to be sure
aackarAuthor Commented:
The log shows the same thing as previously, which is application error 2004, Backup of GPO failed. Error [same error mentioned in above comments]

I also found this link http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Q_28303442.html
Seems like the exact same issue. I checked my schema version and I am at 56 (server 2012)

No solution for that one either. I wonder if this is happening due to my single label domain. Everything else Microsoft related (such as DFS) fails on a single label domain
Will SzymkowskiSenior Solution ArchitectCommented:
Take a look at the following link. Try adding the -domain and -server switches to the command and see if that works.

Reference:
http://stackoverflow.com/questions/19322178/backup-gpo-error

Will.
aackarAuthor Commented:
@Will
That has been tried already
compdigit44Commented:
Have you tried to backup one GP instead of all at once?

Like you mentioned before I too am wondering if this has to do with your single label domain...
https://support.microsoft.com/en-us/kb/300684

Have you run dcdiag /v /e >c:\dcdiag.txt to ensure your AD environment is healthy just to be safe?

I wonder if the GP migration table would work here. I never tried it with a single-label domain though.
https://technet.microsoft.com/en-us/library/cc754682.aspx
aackarAuthor Commented:
I wound up re-creating all of my GPO's in the new domain. Though it was painful, this was the most direct solution for me. I am certain it is due to the single label domain now. After re-creating the GPO's in the new domain (TLD compliant), they back up successfully from there.

Just for grins, I did check the AD health status and it checked out fine. Thanks everyone for the help!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aackarAuthor Commented:
Though this solved the issue, it would be a nightmare re-creating all GPO's in a larger environment. Thankfully I only had about 50 policies to create over.
Ron DokkensirCommented:
Well..
Had the problem on a DC in a VM (Win 2012 Server).

It turned out..
That the ip settings on the server was wrong!

It was set to DHCP (Obtain ip automatically)
Should have had had static IP!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.