Cisco 1760 routing issue

I recently got a new internet circuit that I am planning to use to offer wireless internet to customers with.  I have an old 1760 that I was hoping to handle the routing and DHCP.  I have setup the router and attached the relevant config file.  The public IP has been changed but everything else is how the router is currently configured.  The problem I have is that traffic from the 172.16.7.XXX subnet does not get routed out the internet circuit connected to interface fa 0/0.  The four fast Ethernet ports 1/1 - 1/4 are a WIC 4ESW card.  I have an access point plugged into one of those ports.  I'm not sure if I have something wrong in my config or if you cant route with the 4ESW card?

C--Users-Owner-Desktop-current-config.tx
joshparkerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joshparkerAuthor Commented:
Building configuration...

Current configuration : 2626 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXXXXXXXXXXXXXXXX
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.7.1 172.16.7.50
!
ip dhcp pool ATT_Wireless
   network 172.16.7.0 255.255.255.0
   default-router 172.16.7.1
   dns-server 8.8.8.8 8.8.4.4
!
!
no vlan accounting
!
!
!
!
!
!
!
!
!
!
!
!
username XXXXXXXXXXXXXXXXXXXXXXXX
!
!
!
!
interface FastEthernet0/0
 description ATT Internet Circuit
 ip address 192.168.1.2 255.255.255.000
 speed auto
!
interface FastEthernet1/1
 switchport mode trunk
!
interface FastEthernet1/2
 switchport mode trunk
!
interface FastEthernet1/3
 switchport mode trunk
!
interface FastEthernet1/4
 switchport mode trunk
!
interface Vlan1
 ip address 172.16.7.1 255.255.255.0
!
ip default-gateway 192.168.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
no ip http server
!
!
control-plane
0
RafaelCommented:
Add this into your current config

ip route 172.16.17.0 255.255.255.0 192.168.1.1

[i]
HTH
-Rafael[/i]
0
joshparkerAuthor Commented:
I added the route you suggested, I still am unable to ping from 172.16.7.1 to 192.168.1.1.  This seems like it should be so simple I'm baffled as to what I am overlooking.
0
Defend Against the Q2 Top Security Threats

Were you aware that overall malware worldwide was down a surprising 42% from Q1'18? Every quarter, the WatchGuard Threat Lab releases an Internet Security Report that analyzes the top threat trends impacting companies worldwide. Learn more by viewing our on-demand webinar today!

mikebernhardtCommented:
That route should be removed, it was already covered by your default route. What I'm wondering is if the ISP address is still 192.168.1.1. If that has changed, the default route (ip route 0.0.0.0 0.0.0.0 192.168.1.1) must be replaced with the correct next hop address.
0
joshparkerAuthor Commented:
The ISP address is correct, I can ping it and get out to the internet without problem from the router, its just anything from the 172.16.7.X subnet that is not able to get out, a traceroute shows all of the traffic hits 172.16.7.1 and dies.
0
mikebernhardtCommented:
I don't see any NAT config in your router.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
naderzCommented:
What the result of this command below when run from the router itself?

ping ip 192.168.1.1 source 192.168.1.2

Also, what is the result of the following:

1. show interface fastethernet 0/0
2. show ip route
0
joshparkerAuthor Commented:
I knew it was going to be something simple I overlooked.  Configuring NAT on the two interfaces solved the issue, thank you very much for your help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.