Scanner doesn't work any more on Win 7

I have a scanner/printer on a small network.  From one PC I can both scan and print.  From the other PC the printer works but the scanner has stopped working.  (It has worked in the past but the last time anything was scanned was quite some time ago).

On the problem PC.
The scanner utility does not find the scanner, both in searching and when I enter the IP adress.
I have deinstalled/reinstalled the complete printer/scanner software suite.  No change - print yes, scan no.
I have changed firewall settings, even disabled the firewall.  No effect, the scanner can not be found.

Is there a way to check if the TWAIN subsystem is OK?
What else could I try to repair this problem.


ps.  As is the usual case, the problem PC is the one most likely to use the scanner - ie. next to it.
LVL 46
AndyAinscowFreelance programmer / ConsultantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris MillardCommented:
Do you have any Antivirus/Internet Security on this PC that might be blocking the scanning. Can you connect the scanner via USB to test?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ashok DewanFreelancerCommented:
Is this network printer or has USB cable with it ?
If USB cable printer then check Device Manager after driver installation. In device manager check if any exclamation error appearing. waiting for response
ltpittCommented:
Quite a few things to check.

On the software side:

turn temporarily off any antivirus and give a run to this guys:

https://toolslib.net/downloads/viewdownload/1-adwcleaner/
http://www.bleepingcomputer.com/download/combofix/

You use the SAME software to scan on both pcs (driver / utilities)?

On the hardware side:
Change usb cable and usb port.

What do you get in device manager (windows + pause)?
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

AndyAinscowFreelance programmer / ConsultantAuthor Commented:
It is a network printer/scanner, I'll see if I can connect via a USB cable (might not be today).

The printing works without problem from both PC's.

Both PC's have the same OP system, printer/scanner software suite and antivirus, nevertheless I'll disable the AV on the problem PC temporarily to test.
ltpittCommented:
Disable temporarily any Firewall on the computer (windows or 3rd parties) and try again.
joinaunionCommented:
Has someone disabled network discovery on the problem pc?

Also confirm if file and printer sharing is on.
nobusCommented:
since you said "has stopped working" i assume it was ok before?
then it can be caused by an update - try restoring it to a date it was ok
AndyAinscowFreelance programmer / ConsultantAuthor Commented:
OK, to repeat a couple of points from the original question:
It is connected over the network not via USB.
It did work quite some time ago but I think it was last used to scan months ago - when it did work.
I have already tried changing/disabling the firewall.
The OP system and drivers and AV are the same on both PCs.

After a new start.
When connected via USB cable the scanner is recognised and will scan without problems.  This is with Firewall and AV running.

Disable firewall and AV.  
The USB scanner functions but over the network connection still not working.

Network discovery is turned on and File/Printer sharing is enabled.

So, it looks like everything is functional but something is stopping the connection.  As the scanner is only used occasionally and the USB connection will allow it work then this is now not critical.  It would be nice to find out just what is going on.
Chris MillardCommented:
Does the scanning application itself (i.e. the exe) need to be allowed through the firewall?
AndyAinscowFreelance programmer / ConsultantAuthor Commented:
I have set that to be allowed BUT when the firewall is off it still would not find the scanner.
Chris MillardCommented:
What make and model of scanner is it?
AndyAinscowFreelance programmer / ConsultantAuthor Commented:
Epson SX510W

ps.  I have downloaded the latest drivers/software for it as part of trying to get this fixed.
ltpittCommented:
Those scanners often have more than one scanning api (isis, twain, wia...) why don't you try another one?
You should get the option in the Epson cd / downloaded (complete) setup.
If this is a viable path I suggest you to completely remove all previous stuff with Revo Free  http://www.revouninstaller.com/revo_uninstaller_free_download.html) and try isis or wia.
nobusCommented:
is the scanner seen in device manager? if not -it won't scan
AndyAinscowFreelance programmer / ConsultantAuthor Commented:
>>Those scanners often have more than one scanning api
It does scan via the USB connection but not with the network connection.  Why would changing that make a difference?  (Don't forget it did work via the network some time ago).

>>is the scanner seen in device manager?
Yes, but it is a printer/scanner.  Interestingly the context menu for the USB one has a scan option which isn't in the context menu for the network one.
ltpittCommented:
Something is - I dare to say - wrong on the software side (32 driver - 64 driver or similar). Cutting the dead branch and moving to a virgin one is a workaround, I agree but in the end...
The user needs scanning, right? :)
nobusCommented:
did you try a system restore yet? worth a try before a clean install
ltpittCommented:
The system restore is an option but we have no clues about dates
AndyAinscowFreelance programmer / ConsultantAuthor Commented:
>>did you try a system restore yet? worth a try before a clean install

System restore - I don't know just when it stopped working.  Then after various updates are re-installed who knows if it then is crippled again.
Clean install - no way is that going to happen for something that I can get working via a USB cable for the occasional time something needs to be scanned in.
AndyAinscowFreelance programmer / ConsultantAuthor Commented:
Some further info.
I have temporarily downloaded a trial version of another AV program and let that perform a full scan.
That 'found' one thing said to be a trojan embedded in another file, the trojan being many years old, of low danger and not very common.  The file it was embedded in was in a temp folder of my browser from some time ago.
If it was real then why had my other AV not found it?
Was it a false positive with a slightly different signature?
<Being cynical and paranoid> Was this a deliberate false warning to try to persuade me this AV is better than the other?

Anyway I've cleaned out the temp files from the browser and the scanner still doesn't work over the network on this PC.
AndyAinscowFreelance programmer / ConsultantAuthor Commented:
The USB connection, though not ideal, does allow it to still be used as a scanner.
Other suggestions may well solve the problem for other cases but in this case didn't actually help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.