Removing / Re-installing Java8U40

Two days ago, I successfully upgraded both the 32bit and 64bit versions of Java on a Win7 64bit system from Java8U31 to Java8U40.  Shortly after the upgrade, one of the business websites that uses Java would no longer run.  I received an error message that said a Java Virtual Machine was required to run WebConnect.  However, I was able to verify Java by using the Java verify webpage.  SInce some webstie worked, and others did not, I decided to remove/ reinstall Java.... and here's where things took a morbid turn:

I tried to uninstall Java 8U40 32bit, but received the error, "Can Not find Message File"
I tried to re-install Java 8U40 32bit, but the installer failed with Error 1603

I tried to use the Java Uninstall Tool on the sun website, but surprise, you need Java working in order to run/use the uninstaller
I used the Microsoft FixIt tool, which removed both Java 8U40 entries from the Program & Features window, but I'm still unable to re-install Java
I tried to use the Javara program to remove java, which also appeared to work, but am still unable to re-install

Now, when I try to re-install Java, Error 1603 appears almost immediately after I click on the install button.  Whereas in the beginning, it would at least try to install the files before it would error and abort.

Finally, I ran System Restore.  Both versions of Java8U40 are back in Programs & Features.  Neither version work in IE, and I am still unable to remove or re-install.  I am essentially back at square one.
LVL 1
RobertSystems AdministratorAsked:
Who is Participating?
 
RobertSystems AdministratorAuthor Commented:
I resolved the installation issue via a 2-step process:

1) First, I had to reset the TEMP and TMP environment variables back to their default values.  Having them point to a folder on the D Drive prevented the Java installer from extracting the setup files during the installation process.  However, I found this odd since the installer itself was able to write the log files to the same temp folder on the D Drive.  Plus, other programs installed without issue.  Nevertheless, resetting the environment variables resolved that issue.

2) I had to turn off "java content in the browser" in the Security Tab of the Java Control Panel.  But for some strange reason, I could not do that through the Control Panel.  Instead, I had to follow these steps:
  a) Go to C:\Program Files (x86)\Java\jre1.8.x\bin directory
  b) Run the javacpl.exe executable
  c) Click the Security Tab -> turn off "Java content in browser" -> Click OK
  d) Install the Java8U40 update (32bit)
  e) After a successful installation, repeat steps A-C to turn on "Java content in browser"
0
 
Michael-BestCommented:
Verify Java and Uninstall Out-of-Date Versions:
Link to the Uninstall Java tool:
https://www.java.com/en/download/uninstallapplet.jsp
0
 
Michael-BestCommented:
If my previous post did not help then please read this guide by java.com:
"How do I cleanup the registry after a failed Java uninstall?"
Link:
https://java.com/en/download/help/manual_regedit.xml
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
David Johnson, CD, MVPOwnerCommented:
fyi msi error 1603
The SYSTEM account does not have Full Control permissions on the folder that you are trying to install the Windows Installer package to. You notice the error message because the Windows Installer service uses the SYSTEM account to install software.
0
 
RobertSystems AdministratorAuthor Commented:
@Michael-Best:  I tried to use the uninstall tool, but nothing appeared.  Per the suggestions on the webpage, I tried to access Java in the Control Panel, but the icon was not there.  I manually removed the registry entries, and that removed both Java version from the Programs & Features.  However, I am still unable to install Java.

Out of curiosity, do you think removing the java setup files from the WIndows Installer folder would help?
0
 
RobertSystems AdministratorAuthor Commented:
@David: Are you saying that I need to change the permissions on the Windows Installer folder?  If not, what folder does Java use?
0
 
David Johnson, CD, MVPOwnerCommented:
the destination folder
0
 
RobertSystems AdministratorAuthor Commented:
@David: I tried changing the Java destination folder to C:\Temp, which is Full Access to Everyone.  Unfortunately, I still received the Error 1603 almost immediately after hitting the "Install" button.
0
 
Michael-BestCommented:
Right click the C drive and select the "Tools" tab
In Error checking area, click "Check Now"
Reboot the PC and allow some time for it to complete.
Then download and install java.

If still no go then try MS FixIt:
https://support.microsoft.com/en-us/mats/windows_file_and_folder_diag/en

FYI : Windows 7 Check Disk
https://www.youtube.com/watch?v=9YLnr0DzJTU
0
 
RobertSystems AdministratorAuthor Commented:
@Michael-Best: I ran the chkdsk, and everything reported fine.  I also ran a SMART check, and the health of the drives are good.
0
 
RobertSystems AdministratorAuthor Commented:
I discovered the env variable issue by logging in as a different user, and realizing that the java setup was failing because of a user profile issue instead of a system issue.  That made it much easier to find the problem.

I found the javacpl.exe solution on some random forums site.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.