Asus AM3 M4A785TD-V EVO can't find Samsung 840 SSD

Dear experts,

I hope you can help me out.


I have a computer with the following configuration

- Asus M4A785TD-V EV/o
- Kingston hyper-x 12 GB Ram DDR3
- ATI Radeon 5870
- AMD Phenom X2

I wanted to upgrade my performance by replacing the old 600 GB HDD with an 250 GB SSD.
First i tried to clone it.

it constantly came with the error "Reboot and select proper boot device"
I disconnected all other Sata drives including my DVD-Rom and still got the error message.
I tried recovering with an windows DVD 8 but it continues to say "the harddrive is locked" even a complete reinstall from the repair function came up with an error.

After many tries. i stopped connected the ssd with data to my laptop copied my most important data. and removed all the partitions.
inserted it into my pc. and began a clean install.
well everything went fine. i was able to reinstall windows with 1 C: drive of 250GB. i updated several times. with reboot.

However the next morning i turned it on it was applying updates and i could log in. i searched for updates again and went to work.
at work i logged in using teamviewer and finished the updates by restarting....
it did not came back on.
after work. the same error "reboot and select proper boot device" i restarted and it went back into windows. i could update and restart 4 times. when it came with an memory error. that i could not write during system update. by pressing control alt delete it restarted. and then the same message appeared "reboot and select proper boot device"
In the bios the SSD is not listed.
I also tried to flash the bios to the latest version BIOS 2105. still without any result.

is there anything i can try? a bios setting or something?
the manual says it is compatible with an SSD disk.

I have no ideas anymore. please help :(

Robin
jav_sevenofnineIT ConsultantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gary CaseRetiredCommented:
There shouldn't be any issue using an SSD with that system.

Reconfigure your memory so you only have 2 modules installed (one in each channel so it still works in dual channel mode).     Your memory subsystem will be much more reliable with only 2 modules installed ... 4 modules causes significant deterioration of the address and data bus signals.    Note sure if that's a contributor to your issue -- but it's certainly worth checking.
rindiCommented:
Make sure the SSD's firmware is up-to-date. Maybe use your laptop to do that. Make sure your PC's SATA controller is set to AHCI (or native or SATA), and not RAID or compatible modes.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
also check your cables and connections - swap them if possible

can you connect the SSD to another PC?  to see if it is still accessible?
there is also a chance it went bad
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

rindiCommented:
The utility to upgrade the firmware usually also doubles as a diagnostic tool, so that would tell you it's state.
noxchoGlobal Support CoordinatorCommented:
Two questions:
1) Does the drive have latest firmware?
2) Is this the only drive in system?
jav_sevenofnineIT ConsultantAuthor Commented:
Ok it sure is the SSD disk.
I have installed windows on a 2,5 inch HDD with 0 issues.
It boots evertime.
I have inserted the ssd in a external bay and connected it to my laptop. 0 issues mounting the external disk.
I see partitions and everything.
At the office i had the same issue booting the SSD. so it can't be the hardware.

@garycase, i allready had that issue earlier. I fixed this issue by updating to the latest biosversion.
@rindi : i did not know you could upgrade the firmware of an SSD. could this be a possible cause? i have never done this before. are there manuals for it?
@nobus : I tried several Sata cables and power cables. this is not the issue.
@ noxcho : 1. ) i have no idea. i did not know you could upgrade a ssd firmware. 2.) yes i disconnected all other drives. when testing.
rindiCommented:
Sure the firmware could cause this. You should always make sure you have the newest firmware on your SSD's. Just install the diagnostic tool from your SSD's manufacturer on a PC you have connected it to, then use it to check the firmware and do the upgrade if there is a new version.
jav_sevenofnineIT ConsultantAuthor Commented:
@ all.

I am sorry looks like i have an Samsung 850 EVO instead of 840. can't find any firmware updates on samsungs website. what does that mean? that there is no firmware for this disk?
noxchoGlobal Support CoordinatorCommented:
You need to download and install Samsung Magician tool from here: http://www.samsung.com/global/business/semiconductor/minisite/SSD/global/html/support/downloads.html
Then connect the SSD drive internally (as second drive) and run the tool. Once started navigate to Update section and let it check if you have the latest firmware version.
jav_sevenofnineIT ConsultantAuthor Commented:
got the magician tool working. and got these images.samsung.PNGsamsung-2.PNGsamsung-3.PNG
no firmware available. but it has no bootable os on it. but this has nothing to do that it not shows in the bios. right?
noxchoGlobal Support CoordinatorCommented:
Yes, right. In which mode is the HDD mode set in BIOS? Compatible or AHCI?
jav_sevenofnineIT ConsultantAuthor Commented:
i don't know this but i think its ahci > sata.
but has this something to do that the SSD isn't showing itself in the bios?
noxchoGlobal Support CoordinatorCommented:
If you connect to the same SATA port another HDD - does it show itself there in BIOS?
jav_sevenofnineIT ConsultantAuthor Commented:
Yes! it does! i have currently installed a normal hdd 2.5 inch on exact the same cable and port. its booting and showing up in the bios. no issues at all..
nobusCommented:
can you test this SSD on another system?  it maybe a strange problem it has
noxchoGlobal Support CoordinatorCommented:
Very interesting issue. Any chance you get this drive replaced? If it is still on warranty - send it back and buy new one. Or test it on different system.
jav_sevenofnineIT ConsultantAuthor Commented:
Hey noxcho,

Doing that right now. SSD will be delivered on Thursday! i will let you know.
jav_sevenofnineIT ConsultantAuthor Commented:
well i buyed another disk! a kingston 240GB  SSDnow 300.
i am going to clone it tonight
noxchoGlobal Support CoordinatorCommented:
Does it show up in BIOS? I mean this new one.
nobusCommented:
i have 4 of that brand -  very good up to now -no problems
jav_sevenofnineIT ConsultantAuthor Commented:
Dear noxcho, i will try this tonight. first i will try to clone this samsun SSD. because this drive is much faster then the kingston SSD :)
nobusCommented:
jav sevenofnine - why are you not answering to me?
what did i do wrong to be neglected??
joinaunionCommented:
In your bios select Main page. Then select sata configuration . Select Onchip sata channel and set to enabled.

Once enabled you will now see Onchip sata type select sata if sata doesn't work select ahci.

Just to note if you select ahci mode only sata 1,2,3 and esata can be detected. The samsung drive you have is msata.
jav_sevenofnineIT ConsultantAuthor Commented:
Dear experts,

It is fixed.
For some reason my bios constantly resetted my AHCI settings.
I updated my bios AGAIN. and set it to AHCI. and i could restart with no issues.

Problem solved. its super fast :)

Thanks for your help all!

Robin
jav_sevenofnineIT ConsultantAuthor Commented:
Thanks all for the help ticket closed i can restart without issues now. for some reason my AHCI settings were not set correctly. after rebooting.
rindiCommented:
Maybe if you have problems with the BIOS changing it's settings, a fresh CMOS battery could help.
jav_sevenofnineIT ConsultantAuthor Commented:
thanks for the tip rindi,
Last time i checked the ahci stayed on it's setting. but i will replace the battery just to be sure. :)

Thanks!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Hardware

From novice to tech pro — start learning today.