How to enable mass storage mode on an unrooted android device?

I have a Samsung galaxy s4 and I am trying to enable my mass storage mode on so I am able to back up my data but I cannot find the correct to enable this mode on an unrooted device.
Harman KaurAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gerwin Jansen, EE MVETopic Advisor Commented:
How are you connecting the storage? Internal SD card or an external 2-in-1 Micro USB flash drive?
Harman KaurAuthor Commented:
I don't have a SD card. I am using a micro usb cable
CompProbSolvCommented:
On my S3 I swipe down on the top of the main screen, which brings up "Connected as an installer".  If I tap on that then I get the option to check "Media device (MTP)".  The PC then sees it as an external drive.

If this doesn't work, make sure that the PC is loading the correct drivers.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

KRUNAL TAILORFreelance Mobile DeveloperCommented:
Hi Harman Kaur,

Method :1 (Old android version method)
In android device
- go to Settings
- Wireless & Wifi
- USB Tools
- Connect USB mass storage to PC.

OR

Method :2
For Android 4.2 or newer (e.g. Samsung Galaxy S4):
- Enter "Settings"
-  Click "About Phone"
-  Tap "Build number" for several times until getting a note "You are under developer mode"
-  Back to "Settings"
-  Click "Developer options"
- Check "USB debugging".

Let me know if this helps or not. But for mass storage mode you may need to root your device or use a 3rd party app for new android version. I tried Method 1 for gingerbread 2.3 not sure about new android version.

Thanks & Regards,
Krunal T. Tailor
Gerwin Jansen, EE MVETopic Advisor Commented:
Are you connecting to a PC? What OS? When you connect it, what sounds do you hear?
Harman KaurAuthor Commented:
I am using a HP laptop.
Harman KaurAuthor Commented:
I tried Method two but it doesn't seem to work with the software that I am using to recover my data. I am using Wondershare Dr. Fone. I keep getting a pop up that tells me to root my device first.
CompProbSolvCommented:
Do you see the device in Windows Explorer?
joinaunionCommented:
Use method 2.
And use Kies to recover.
http://www.samsung.com/ca/support/usefulsoftware/KIES/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gerwin Jansen, EE MVETopic Advisor Commented:
@Harman Kaur - You are only partially answering my questions, I'm unsubscribing. Hope you get your issue solved.
Harman KaurAuthor Commented:
@Krunal Tailor
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Android

From novice to tech pro — start learning today.