Word 2010 alt 0247 does not enter division sign ÷

The alt 0247 keyboard shortcut used to work in office 2003, but in my word 2010 it doesn't.

I have a Quick Access Toolbar defined.  When I key alt 0247,  MS Word treats it like alt 2, and executes the second icon in the QAT toolbar.

I did a workaround by insert > symbol > arial > 0247, but I was wondering if there is a way to make alt 0247 work?
LVL 5
rberkeConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

GrahamSkanRetiredCommented:
Hello,
It may be some help to know that it doesn't work in Word 2007. Insert symbol creates an 'e' crossed out as if with an acute accent. This is the pasted-in character:  'ɇ', but I'm not sure that it will survive the HTML process
0
GrahamSkanRetiredCommented:
Note. I see by viewing my previous post that the character appears here as it does in Word.
0
Steven CarnahanNetwork ManagerCommented:
GrahamSkan - Actually I have Word 2007 and just tried it.  I did indeed get the divide symbol:  ÷

It may have something to do with the font.

EDIT:  I used the alt code in my post to display the symbol as well.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

GrahamSkanRetiredCommented:
pony10us,

Thanks for the contribution. I didn't get any symbol at all. I think that we may have an under-researched problem here
0
Steven CarnahanNetwork ManagerCommented:
I agree, since I do not have access to Word 2010 I don't know the exact answer however from doing a little searching it appears that it may either be related to the font (try New Times Roman) or the Normal.DOTX file.
0
Paul SauvéRetiredCommented:
I have Word 2010 / Windows 7 Hove Premium & I get ÷ both in Firefox and Word using Alt 0247

But I have to use Alt 246 (WITHOUT the leading zero) to get the same character in both!
0
GrahamSkanRetiredCommented:
Hmm rberke,

As you see, none if us has a definitive answer as yet. How would you describe the symbol that you need?
0
Steven CarnahanNetwork ManagerCommented:
Paul,

That is an interesting point (the two codes)  Here is what the difference between them:

ALT+246 yields '÷', which the code 246 are referred form MS-DOS code page 437.
 ALT+0247 yields '÷', which the code 0247 are referred from Windows-1252 character encoding.
0
Steven CarnahanNetwork ManagerCommented:
While not specifically associated with Word you may want to look this over:  http://www.forlang.wsu.edu/help/keyboards.asp

It again references the font as a possible issue bringing me back to what I originally stated.  Please try with a different font.
0
rberkeConsultantAuthor Commented:
GrahamSkan specifically asked "How would you describe the symbol that you need?"
Answer: Two ways to describe it.   #1 "I want a division sign"
                                                           #2 is more precise, I want the same thing  you see if you insert > symbol > arial > 0247


But, so far, none of the responders have come anywhere close to answering my real question.

What I really want is a way to insert any Unicode character using the old fashion Word shortcut method of Alt xxxx
 
For instance, in the pony10us link you will see the following statement but it only applies to Word 2003.  I want something that works in Word 2010.

If you know the *Unicode (hexadecimal) value of any character, you can use the "ALT X" keyboard shortcut to enter the character directly in your document in some programs such as Microsoft Word.

Another workaround I have developed is the following VBA macro.
Sub WorkAround()
    Selection.TypeText Text:=ChrW(InputBox("enter unicode"))
End Sub

But, I am beginning to think that Office 2010 has eliminated the ability to enter symbols directly with keyboard alt key shortcuts.
0
rberkeConsultantAuthor Commented:
It is ugly but, this gets the job done, so I plan on PAQing this question.  The solution I devised for myself was put the following macron into my normal template, then assigning it to QAT function 1.  
In the past, with Word 2003 I would type alt 0247 to get the division sign symbol.
now, with my Word 2010 I will type alt 10247 to get the same symbol.

Sub WorkAround()
     Selection.TypeText Text:=ChrW(InputBox("enter unicode"))
 End Sub

Open in new window



This is entirely my own solution, and previous expert comments played no role in this solution, so I cannot award points.

Thanks for trying.

rberke
0
rberkeConsultantAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for rberke's comment #a40719715

for the following reason:

This is entirely my own solution, and previous expert comments played no role in this solution, so I cannot award points.
0
GrahamSkanRetiredCommented:
Thanks for showing us your getaround
0
Rob HensonFinance AnalystCommented:
I have Windows 2010 and using Alt +0247 gives me the Division symbol ÷ as expected.

When looking at the Insert Symbol window there is a selection drop down titled "From:". In this I have three options
1) Unicode (hex)
2) ASCII (decimal)
3) ASCII (hex)

If I have option 1 selected and type 0247 in the Character code box, it shows the crossed out e in the table above. With option 2 selected it shows the division symbol as expected.

Maybe there is a setting somewhere which tells Word which of these to use when using the keyboard shortcut.

Thanks
Rob H
0
rberkeConsultantAuthor Commented:
Are you sure the keyboard short works on your computer?  And, are your sure you have ms Word 2010 (your post said "Windows 2010" which makes no sense.)

My trouble is  that QAT interferes  with the keyboard shortcut Alt 0247 and that is my ONLY problem. I can easily accomplish my goals in many other ways, it is only the keyboard Alt 0247 that does not work.

If alt 0247 works on your computer, and does not work on mine, then there must be some difference.

I have a theory: perhaps your version of Office 2010 somehow has the Quick Access Toolbar deactivated?  That would explain why alt 0247 works for you and does not work for me.   Can you turn on QAT and test it again on your computer?

If you can confirm that alt 0247 worked before you activated QAT and failed afterwards, I will award you the points.

By the way, I tried alt 0247 on an office 2013 computer and it does not work there either.


bob
0
Rob HensonFinance AnalystCommented:
Apologies, for Windows 2010 should have said Word 2010

And yes, I am sure it works and the QAT is "activated", don't know of a way to de-activate it.
0
Rob HensonFinance AnalystCommented:
When I do the Alt +0247 I am keeping the Alt key pressed while I type the 0247, on release of the Alt key it populates the division symbol.
0
Steven CarnahanNetwork ManagerCommented:
One more thing.  It may have been covered above however be sure you are using the number keypad and NOT the numbers across the top.  

One of the big issues that I have seen since the introduction of the "Ribbon bar" in 2007 is that you press and release the Alt key it causes number and letter shortcuts to appear on the bar. As stated by Rob, you need to keep the Alt key pressed while pressing the number sequence entirely or you risk performing a "shortcut" sequence instead.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rberkeConsultantAuthor Commented:
I do the exact same thing on word 2010 and it does not work.

There must be some difference in our settings, but I have no idea where to look.  I did a quick scan of the normal suspects, like options Advanced, but I don't see anything likely.

By the way, I checked with a brand new Office 2013 install with no setting modifications.  And alt 0247 does not work on it.
0
Steven CarnahanNetwork ManagerCommented:
There are two methods of inserting characters using the "Alt" key.

Using Alt+0247 results in: ÷          This is the ASCII character
Using 0247 then Alt+x results in: ɇ       This is the Unicode character

It appears that you are somehow inserting Unicode instead of ASCII.

According to:  http://www.unicode.org/charts/PDF/U0180.pdf

0247 ɇ LATIN SMALL LETTER E WITH STROKE
0
Rob HensonFinance AnalystCommented:
Are you keeping Alt pressed while typing 0247 with the number pad?
0
Steven CarnahanNetwork ManagerCommented:
The ASCII version is Alt+246: ÷
0
rberkeConsultantAuthor Commented:
pony10us:  I am  the author of the post and I have NEVER said I was getting ɇ.

But, I reread your 12:41 comment  and saw that you had the PERFECT solution.  
One more thing.  It may have been covered above however be sure you are using the number keypad and NOT the numbers across the top."  


That was it.  Thanks a bunch,  !!!!!
0
rberkeConsultantAuthor Commented:
Great job.  Thanks
0
Steven CarnahanNetwork ManagerCommented:
Not a problem, glad to be of help and you are correct, I went back and noticed that it was the first response that mentioned the ɇ.  Sorry about focusing on that but the research did provide me with some new information.  :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Word

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.