Suse Linux - how to know if server connects to internet

new to linux -  my linux knowledge is  - google as I go -
I have a linux box with Suse Enterprise  SP  
need to know if this one connects to internet
( I am trying to upgrde online and it seems the machine does not )

need some help please.
indikadAsked:
Who is Participating?
 
omarfaridCommented:
connection time out could be due to:

1- Routing issue to the DNS server
2- Some firewall blocking you from reaching DNS server

Check with your network admin
0
 
Manfred BertlManagerCommented:
Can you ping - for example - www.google.com? Or at least an outside ip address like 8.8.8.8? If not, you have network connection problems. If yes, it seems your 'you' (Yast online Update) cannot connect to the repository servers. The reason could be a subscription problem.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
omarfaridCommented:
Is your DNS configured? Is your routing has default router that can take you to the Internet?
0
 
indikadAuthor Commented:
ping www.google.com
gives me unknown host

ping 8.8.8.8
gives me network unreacheable

Note:  The server is on our network behind the same router. If I do a ipconfig from a windows machine I get an ip address 192.168.229.200
so I belive the router address that the linux box give is wrong.

I sort of think if the server can detect my router then it will get to internet - but I don't know where to set that up.

route command  on the linux machine gives me this
hanab1:~ # route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0
192.168.229.0   0.0.0.0         255.255.255.0   U     0      0        0 eth0


and
hanab1:~ # ip route show
127.0.0.0/8 dev lo  scope link
169.254.0.0/16 dev eth0  scope link
192.168.229.0/24 dev eth0  proto kernel  scope link  src 192.168.229.149

Open in new window



ifconfig gives me the below
******************************************
eth0      Link encap:Ethernet  HWaddr 00:19:99:E2:02:43
          inet addr:192.168.229.149  Bcast:192.168.229.255  Mask:255.255.255.0
          inet6 addr: fe80::219:99ff:fee2:243/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:222760883 errors:0 dropped:101167 overruns:0 frame:0
          TX packets:234661136 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:67491681832 (64365.0 Mb)  TX bytes:35237886043 (33605.4 Mb)
          Memory:df920000-df940000

eth1      Link encap:Ethernet  HWaddr 00:19:99:E2:02:44
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Memory:df900000-df920000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1374264864 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1374264864 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:290668111578 (277202.7 Mb)  TX bytes:290668111578 (277202.7 Mb)
*******************************************************
0
 
indikadAuthor Commented:
in addition to my reply just before this ( pelase check )
also --  the
/etc/sysconfig/network/ifcfg-eth0
has these information.  below. Asuning the NETWORK= is the router address, should I change the address of the NETWORK= ?    -   do I need a restart of the server ? and what consequences could there be ?


BOOTPROTO='static'
BROADCAST='192.168.229.255'
IPADDR='192.168.229.149'
NETMASK='255.255.255.0'
NETWORK='192.168.229.0'
NAME='Intel Ethernet controller'
STARTMODE='auto'
USERCONTROL='no'
0
 
omarfaridCommented:
It seems no default gateway is set.

Please find out your default router IP address (from network admin or from some other m/c connected to Internet) and add. Please see steps in below link:

http://seriousbirder.com/blogs/add-default-gateway-in-suse-linux/

under "Add default gateway in SUSE Linux"
0
 
indikadAuthor Commented:
omarfarid thanks . I could not be sure how to correctly do using your link but I used YasT to update hoping it will do the same job - hope someone can advise
this is what I did and the result

yast - network devices - network settings - routing
default gateway set an ip address to 192.168.229.200
and after a reboot of the system found this line in the routes file
default 192.168.229.200 - -

rebooted the system and also did a manual start of the network but still cannot ping  - same results as before if I ping www.google.com  ,  I get unknown host
0
 
Manfred BertlManagerCommented:
can you ping 192.168.229.200 ?
0
 
omarfaridCommented:
What about your DNS setup?

If you run command like:

nslookup www.experts-exchange.com

What do you get?

If dns is not setup then you need to configure it. You may use yast for this. Please see link:

http://www.pcc-services.com/sles/dns.html
0
 
indikadAuthor Commented:
mbertl -
yes I can ping  192.168.229.200

omarfarid
nslookup www.experts-exchange.com
gives me below
;; connection timed out; no servers could be reached
I will check your link re DNS
0
 
indikadAuthor Commented:
I am still in the process of solving this however closing this to stop the question falling in to "abandoned" stage.
Thanks very much for all who took time to reply.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.