ASA SIte to Site VPN not working

OK I am really having an issue configuring site to site VPN.
I use the wizard and I select my peer network address of 72.x.x.x
Type in my passphrase jkljkad
Select the default encryption of 3DES SHA 2
Local Networks 192.168.2.0/24 as a network object Group
Remote Networks 192.168.0.0 /24 as a network object group
Checked the Exempt ASA inside
Then Click Finish
Then when I apply the changes to the router the Exempt ASA is unchecked and when I go into it and check and apply it I get this error message:

nat (inside,outside) 1 source static PMP PMP destination static KFAB KFAB
      
nat (inside,outside) 1 source static PMP PMP destination static KFAB KFAB
           ^
ERROR: % Invalid input detected at '^' marker.

No matter what I try to change the any of the network IP addresses I still get the same error. I even tried just straight IP addresses.  I appreciate any insight is appreciated!
Brian SchraederI.T.Asked:
Who is Participating?
 
Brian SchraederI.T.Author Commented:
the solution was to upgrade the IOS to a new version and it resolved the problem
0
 
arnoldCommented:
Do both sides have static IPs?
I.e. when you define the crypto policy peer address static_IP_of the other?
At which stage of the VPN setup does the failure occur, first stage or second.

The remote has the reverse rule
192.168.0.0/24 local
192.168.2.0/24 remote?
0
 
Brian SchraederI.T.Author Commented:
Do both sides have static IPs? Yes

At which stage of the VPN setup does the failure occur, first stage or second. - unknown I go through the wizard and goes all the way through.  The only time I get the error is when I edit the rule and I apply it.
0
Prepare for an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program curriculum features two internationally recognized certifications from the EC-Council at no additional time or cost.

 
arnoldCommented:
Does the VPN exist that you are modifying or is this VPN just being setup?

Look at the ASA logs.
0
 
Brian SchraederI.T.Author Commented:
The VPN that I am just setting up.
0
 
arnoldCommented:
Do you have access to both ASA's at the same time?

It is not clear what error or why you are getting it.

Please make sure the local lan, remote gateway is correct.
Could it be you are placing the wrong segment as local on the wrong ASA?
0
 
Brian SchraederI.T.Author Commented:
Yes I have access both ASA's at the same time.  The one ASA with ASDM version 7.1  I have no issues at all and that is configured correctly however when I try to setup the ASA with ASDM version 7.3 I run into this issue.

Here is a current list of the ASA that I am having a problem with:

hostname PMP
enable password ######## encrypted
passwd ########## encrypted
names
name 192.168.2.128 PatriotServer description PMP Main Server
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
object-group service TCP3389 tcp
 port-object eq 3389
object-group service RDP tcp-udp
 port-object eq 3389
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group network KFAB
 network-object 192.168.0.0 255.255.255.0
object-group network PMP
 network-object 192.168.2.0 255.255.255.0
access-list outside_access_in extended permit tcp any interface inside eq telnet
access-list outside_access_in extended permit object-group TCPUDP any any object-group

RDP
access-list outside_access_in extended permit tcp any host 192.168.2.1 eq https
access-list outside_1_cryptomap extended permit ip object-group PMP object-group KFAB
access-list inside_nat0_outbound extended permit ip object-group PMP object-group KFAB
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-731.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 PatriotServer 3389 netmask 255.255.255.255
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 72.9.22.0 255.255.255.0 outside
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA-TRANS mode transport
crypto ipsec transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-AES-128-MD5-TRANS mode transport
crypto ipsec transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA-TRANS mode transport
crypto ipsec transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5-TRANS mode transport
crypto ipsec transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-SHA-TRANS mode transport
crypto ipsec transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-MD5-TRANS mode transport
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA-TRANS mode transport
crypto ipsec transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5-TRANS mode transport
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-SHA-TRANS mode transport
crypto ipsec transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5-TRANS mode transport
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer 72.9.22.197
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca trustpoint ASDM_Launcher_Access_TrustPoint_0
 enrollment self
 subject-name CN=192.168.1.1,CN=PMP
 crl configure
crypto ca trustpoint ASDM_Launcher_Access_TrustPoint_1
 enrollment self
 subject-name CN=192.168.1.1,CN=PMP
 crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
crypto ca certificate chain ASDM_Launcher_Access_TrustPoint_0
 certificate a2d30654
    308201e7 30820150 a0030201 020204a2 d3065430 0d06092a 864886f7 0d010105
    05003038 310c300a 06035504 03130350 4d503114 30120603 55040313 0b313932
    2e313638 2e312e31 31123010 06092a86 4886f70d 01090216 03504d50 301e170d
    31343039 30333038 34353130 5a170d32 34303833 31303834 3531305a 3038310c
    300a0603 55040313 03504d50 31143012 06035504 03130b31 39322e31 36382e31
    2e313112 30100609 2a864886 f70d0109 02160350 4d503081 9f300d06 092a8648
    86f70d01 01010500 03818d00 30818902 818100ce 4c948c38 cec3ceee 490ad3d3
    82d9fbdf aa00662a a30c4c42 7ae52d4c 644ff9e3 e341b9b4 77c183e2 d7487e3c
    82cfa3d5 8056d151 d44a7ab5 4c4a1684 1b6484ee 342d80c2 f62d4531 0d671c58
    d31f7da1 763029c9 1d0e0506 f04a4a1e d8692fa0 4bb04213 162f887f 4aca00e4
    43afafe3 4b22fd8c 3cb5564f b1d7331b 36e42102 03010001 300d0609 2a864886
    f70d0101 05050003 81810094 fe01fb24 7980592e 47eb02bb 2cbff63a 07727d1d
    fa439da8 e01d6cf5 a5598fe7 824ace0e 434910ec 36ff6c97 efaf52b7 da7c3032
    bb827c4a ed0ec830 0391fefe 646ba718 e736a6d7 137ba343 742a9071 f8f93e25
    20cfa271 8abce631 38c284b3 f8718434 9229d918 a45d991d 51ba0952 88b04da1
    0d5c0d6d 3a9fa3b1 d9a077
  quit
crypto ca certificate chain ASDM_Launcher_Access_TrustPoint_1
 certificate 2a040754
    308201e7 30820150 a0030201 0202042a 04075430 0d06092a 864886f7 0d010105
    05003038 310c300a 06035504 03130350 4d503114 30120603 55040313 0b313932
    2e313638 2e312e31 31123010 06092a86 4886f70d 01090216 03504d50 301e170d
    31343039 30343130 35373132 5a170d32 34303930 31313035 3731325a 3038310c
    300a0603 55040313 03504d50 31143012 06035504 03130b31 39322e31 36382e31
    2e313112 30100609 2a864886 f70d0109 02160350 4d503081 9f300d06 092a8648
    86f70d01 01010500 03818d00 30818902 818100ce 4c948c38 cec3ceee 490ad3d3
    82d9fbdf aa00662a a30c4c42 7ae52d4c 644ff9e3 e341b9b4 77c183e2 d7487e3c
    82cfa3d5 8056d151 d44a7ab5 4c4a1684 1b6484ee 342d80c2 f62d4531 0d671c58
    d31f7da1 763029c9 1d0e0506 f04a4a1e d8692fa0 4bb04213 162f887f 4aca00e4
    43afafe3 4b22fd8c 3cb5564f b1d7331b 36e42102 03010001 300d0609 2a864886
    f70d0101 05050003 81810004 6954d466 fcaa3afd ee04837e e44c6d6c 091d9706
    80d48468 e7eb0aa6 3aa97ca6 a98bc372 76339560 f4cab316 2d7a54a8 a5f1902b
    cfc92322 6c4c36d9 6a031d0d 646c342f f562ab24 63375438 110cea4f b9503913
    a4f4fd56 c52a7e19 e266198c e47ea0a1 488d6d16 1069bb8c 1aef3ffd 4c386a9f
    95b88f82 20057434 21e4b7
  quit
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 50
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.2.0 255.255.255.0 inside
telnet 74.214.34.0 255.255.255.0 outside
telnet timeout 60
ssh 192.168.2.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcp-client client-id interface outside
dhcpd auto_config outside
!
dhcpd address 192.168.2.10-192.168.2.25 inside
dhcpd dns PatriotServer 4.2.2.2 interface inside
dhcpd lease 99999 interface inside
dhcpd domain PATRIOTMETALPRO interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate

200
ssl trust-point ASDM_Launcher_Access_TrustPoint_1 inside
ssl trust-point ASDM_Launcher_Access_TrustPoint_1 inside vpnlb-ip
webvpn
 enable outside
group-policy PMP-VPN internal
group-policy PMP-VPN attributes
 vpn-tunnel-protocol IPSec webvpn
 webvpn
  url-list none
username cisco password ########### encrypted privilege 15
username pmp password ############ encrypted privilege 15
username pmp attributes
 vpn-group-policy PMP-VPN
tunnel-group PMPVPN type remote-access
tunnel-group PMPVPN general-attributes
 default-group-policy PMP-VPN
tunnel-group 72.9.22.197 type ipsec-l2l
tunnel-group 72.9.22.197 ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous
Cryptochecksum:1b0e76be6565cf76df8711a3a6993184
: end
0
 
arnoldCommented:
Your error points to two lines that I skipped over, why are you double referencing the IP segment object in your nat (inside, outside) ?


nat (inside,outside) 1 source static PMP PMP destination static KFAB KFAB

This line is the issue.

The VPN will be only on the (inside)  no boundary crossing for this traffic if I understand what it is you are trying to do.
Presumably this is the VPN traffic rule on the LAN..
0
 
Brian SchraederI.T.Author Commented:
When I created a network group and entered the IP address of my network it produces a second name by itself I am not doing anything.  I have attached a word document of each step of the process so you can see what I am seeing.
Doc1.docx
0
 
Brian SchraederI.T.Author Commented:
just got lucky
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.