Problem while trying to raise domain/forest level

Domain Function raising error
The server that it is saying is causing the problem has been gone (hard failure) for a very long time.  I cant seem to find it in ADSI edit or the admin panel.  Any thoughts on where I should start looking.  Last piece of this puzzle.
jkandrisAsked:
Who is Participating?
 
jkandrisAuthor Commented:
Just as a side note.  the folder was empty and I deleted the container and I was able to raise the level without issue after that..
0
 
Benjamin MOREAUProject ManagerCommented:
You have to clean your AD of any reference to this old server.

Have you already run a metadata cleanup ?

https://technet.microsoft.com/fr-fr/library/cc816907%28v=ws.10%29.aspx
0
 
Will SzymkowskiSenior Solution ArchitectCommented:
As stated in the screenshot it is still located somewhere in AD. I would run the following commands...
- netdom query dc
Check Sites and Services to ensure that there are no old DC's located in there (delete it if you see it)
- Check SRV Records to ensure that it is not listed. (this is the _msdcs.domain.com folder under your AD domain.com in DNS)

Also, based on the screenshot, have you actually checked the exact location which it is referencing in the error message. Use ADSIEdit and ensure that you are looking in the correct location.

Will.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Sreejith SugathanSenior Network Support EngineerCommented:
If you have already done the metadata clean-up for the server, it certainly is the DNS records that is creating the issue, Go through each node in the DNS zones and remove any entries related to the server. Have had instances where the metadata clean-up has failed to remove all the entries form the DNS zones.
0
 
jkandrisAuthor Commented:
Well Folks it has been a busy morning, but I can find no instance of the old server in any of those places.  I went through DNS line by line nothing.  Ran Meta data cleanup this is the error I am getting...NTDS-meta-data-cleanup-error.jpg
Any ideas or I am just doing it wrong lol
0
 
jkandrisAuthor Commented:
The entry that it is stating is causing the issue I cant seem to find.  I managed to find where the NTDS settings where and nothing was listed there referencing that server. nothing with DSquery, metadata cleanup, ntdsutil, and I even ran a script that I found and the only server it shows is my active one (https://gallery.technet.microsoft.com/scriptcenter/d31f091f-2642-4ede-9f97-0e1cc4d577f3)

Any thoughts folks.  Fortunately,all else is working I just cant raise the function level..
0
 
compdigit44Commented:
CAn you do a dcdiag /v /e >c:\dcdiag.txt and post the results so we can see if it is listed
0
 
jkandrisAuthor Commented:
I should have stated this from the beginning.  Im not the best AD guy and I have inherited this mess..  So let me say thank you in advance to everyone.  If you see something jacked up please tell medcdiag.txt
0
 
compdigit44Commented:
What is server VACODC2? I am seeing the following error for it...."failed test KccEvent"

As Benjamin MOREAU posted earlier, did you follow "all the steps" to cleanup an old DC from AD??
0
 
jkandrisAuthor Commented:
Dc2 was rebooting it is a backup
0
 
compdigit44Commented:
OK but did you follow all steps for the meta data cleanup??? This is how you can remove the old server
0
 
jkandrisAuthor Commented:
Yes I did.  A couple of times..
0
 
Will SzymkowskiSenior Solution ArchitectCommented:
What are the outputs when you run the following commands...

repadmin /replsum
repadmin /showrepl
repadmin /bridgeheads

netdom query fsmo
netdom query dc

Have you checked Sites and Services as well to ensure that you have remove the entries from there? Based on your initial screenshot it is clear that this objects exist in ADSIEdit at the location specified. Double check that you are looking in the correct area.

Will.

Will.
0
 
jkandrisAuthor Commented:
ADSi-edit-location.jpgnetdom-query-dc.jpgnetdom-query-fsmo.jpgrepadmin-bridgeheads.jpgrepadmin-replsum.jpgrepadmin-showrepl.jpg
Here are the results and the ADSI edit location.  This server has been gone for many years apparently.
0
 
jkandrisAuthor Commented:
sites-and-services.jpg
Sites and services
0
 
jkandrisAuthor Commented:
The server in question that we are trying to find has been gone for many years..
0
 
compdigit44Commented:
stupid question but in ADUC have you gone to View -> ADvanced Features an see if anything is listed in Lost&FOund?

Any old WINS records??? Local host files???
0
 
jkandrisAuthor Commented:
No such thing as a stupid question.  Yes I looked and it is empty.  Nothing in the other places as well
0
 
Will SzymkowskiSenior Solution ArchitectCommented:
What folder was empty/deleted?

Will.
0
 
jkandrisAuthor Commented:
The NTDS setting folder under lost and found folder in ADSi edit.
0
 
jkandrisAuthor Commented:
It was what finally worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.