Server 2012 R2 hyper-v VM won't auto restart

The Automatic Start Action is set is to "Always start this virtual machine automatically." I have a time delay of 3 min.

The VM will not auto restart when the host is restarted, and I have to start it manually.

???

Thanks

Mark
markperl1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
What is your shutdown action? There was a bug (patched) in 2012 R2 where VMs were not being shut down cleanly if that was your selected action. Pausing VMs (which I recommend anyays) worked fine. So if you haven't fully patched and you are choosing to have hyper-v shut down VMs during a restart, you may be hitting this bug.
markperl1Author Commented:
Server is fully patched, and this occurs during  a normal restart of the host. The VM's auto-restart had previously worked just fine! I would not normally shut down the VM before restarting the host.
Cliff GaliherCommented:
I am not talking about *you* shutting down the VM before restarting the host.  I am referring to the "automatic stop action" that can be set per VM.  If you set it to save (pause) then all works well.  The "shut down the guest" has/had a bug that doesn't work right, and seems isolated to 2012 R2.  I have not read/heard that this bug also impacts "turn off the virtual machine" setting, but since that doesn't initiate a graceful shutdown *or* save/pause the VM, I've never seen that used in production either, so it very well could.  I'll see if I can dig up the KB article, as it may still be a hotfix-only release, but I thought it was a fully released patch a few months back...

But, as I said, if you set the automatic stop action to save then you never hit this bug anyways.  So other VMs and other machines configured differently (or 2008 R2/2012 non-R2) won't exhibit this behavior.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cliff GaliherCommented:
Check your update history and make sure you have KB2887595 installed.  If not, install it.
markperl1Author Commented:
Aha! That's what it was. Someone else had been doing some maintenance on the server and changed the Stop Action to Shutdown. Thank you!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.