Updating Video Driver on an Apple iMac

Hi, I have a "late 2012" iMac running Yosemite version 10.10.3. The machine has a 3 TB hard drive, most of which is not in use, 32 GB of RAM, a 3.4 GHz Intel Core i7 processor and a NVIDIA GeForce GTX 680MX 2048MB video card. As you can see, this is not a bottom of the line machine. Its rather hefty.

For the first couple of years, I was on cloud 9. I loved my iMac, which gave me ZERO problems - now, not so much!

Ever since I installed Yosemite I've been experiencing issue. The most recent and problematic of which is the reason for this post. -- Every time I visit sites like Zillow.com or eBay.com or anything with intense web images,  my machine reboots on its own, shortly after leaving the site.

I've uninstalled Norton 360 and reinstalled a fresh version from the Norton site. I've run the Apple hardware system tests multiple times in both standard (about 5 minutes) and extended mode (over 2 hours) and each time I get -- "no problems found." I've rebooted and done it again and again and still nothing on the hardware side.

So, I wanted to upgrade my NVIDIA GeForce GTX 680MX video driver, just in case it might have become corrupt. - I went to the NVIDIA web site and found a new driver (WebDriver-346.01.02f01), which NVIDIA states its for Yosemite 10.10.3. However, when I try to install it, I get the following error message:

         Computer not supported
         This computer is not compatible with the NVIDIA Web Driver.

The installer closes down thereafter.

OK, so what am I doing wrong? How do I update my NVIDIA driver to the latest version to work with Yosemite?

Thank you,
Fulano
Mr_FulanoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
It should update automatically when you run software update. How do you know that you don't already have the latest driver?

Have you looked at the console logs to see what error messages are spawned immediately before your computer crashes? That is more likely to lead to a solution than randomly replacing drivers.

Also, does the problem occur while Norton is not installed?
0
Mr_FulanoAuthor Commented:
Hi Strung, let me address your questions individually.

1). I believe I do have the latest driver. When I go to the NVIDIA webs site it says I do have the latest GeForce 355.02 driver installed. So, what I wanted to do is *reload* the driver to make sure its not corrupt.

2). I have not gone to the console logs to view the error messages before a crash. I'm not sure how to do that. Can you please explain how?

3). I don't know about it occurring when Norton is uninstalled. I would have to surf the net with Norton uninstalled for a while, and that's a risk I don't want to take. Cleaning out a virus is not something I want to do.

Fulano
0
strungCommented:
Open Console.app which is found in the /Applications/Utilities folder. Check the console logs for a period just before the computer rebooted.

By the way, the risk of surfing the web in a Mac without antivirus protection is minimal.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

Mr_FulanoAuthor Commented:
Hi Strung, I found the logs. I also cleared the PRAM, which may have been corrupt. I'll discuss this below, but first, I found the logs and will monitor for errors over the next couple of days.

As for the PRAM...I noticed a few weeks ago, kind of around the time the reboots began, that whenever I started my machine I no longer got that guitar sting "baarummm" sound (hard to describe), but as soon as I cleared the PRAM, it came back. Perhaps this had something to do with the reboots.

For a couple of days, I'm going to surf Zillow and eBay and see if I can generate a reboot, which was not hard to do before.

I'll update this post in a couple of days.

Thanks,
Fulano
0
Mr_FulanoAuthor Commented:
Hi Strung, I did some Zillow and eBay surfing, but no reboot yet...however, what I am seeing the the console logs are the following - each time I start Safari.

4/14/15 1:51:09.894 AM com.apple.WebKit.Plugin.64[1593]: Failed to connect (colorGridView) outlet from (NSApplication) to (NSColorPickerGridView): missing setter or instance variable

4/14/15 1:51:09.894 AM com.apple.WebKit.Plugin.64[1593]: Failed to connect (view) outlet from (NSApplication) to (NSColorPickerGridView): missing setter or instance variable

4/14/15 1:51:13.649 AM PluginProcess[1598]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.3 instead of 10.10.3. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:

4/14/15 1:49:41.914 AM nsurlstoraged[422]: writeDBwithCachedResponse-ERROR: task-mgr=com.apple.WebKit.Networking-write (_dbWriteConnection=0x7ff71a5298d0) insert SQL stmnt. is nil for item:


This one below is seems to be the most severe, because of the Warning comment and the part about the wrong version:

4/14/15 1:51:13.649 AM PluginProcess[1598]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.3 instead of 10.10.3. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:

Are my Safari cache databases corrupt? If so, how do I correct this?

By the way, what is the WebKit the logs keep referring to?

Thanks,
Fulano
0
strungCommented:
I suspect that error has something to do with the Adobe Flash plug in. Try updating it from the Adobe site.
0
David AndersTechnician Commented:
WebKit is an open source web browser engine.

RESET Safari
 1   Open your Safari web browser by clicking on the Safari icon in the dock.
 2   Click on Safari in your Safari menu, located at the top of your screen.
 3   A drop-down menu will now appear. Choose the option labeled Reset Safari....
 4   A warning dialog will now appear detailing the items that will be removed.
 5   Click the button on the dialog labeled Reset to complete the process.
    Your Safari browser will now restart automatically.
0
serialbandCommented:
Webkit is the website rendering engine that many browsers, including Yosemite's Sarari, use.  Those errors suggests that Adobe flash needs to be updated as strung suggests.

Yosemite's Safari no longer has the Reset Safari function.  Now that it uses Webkit, it has a Clear History and Website Data where the Reset Safari menu item was.  This is the same as on Chrome, OperaBeta, Chrome Canary and other Webkit based browsers.  

If you want to fully reset Safari, you can detele your ~/Library/Safari and the next time you start Safari, it will start up with a brand new profile.  That's much more complete than even the Reset Safari function of older Mavericks and prior versions.

Since Safari is using Webkit anyway, you might as well try one of the other Webkit based browsers that have more features and plugin/addons with better adblocking and flash element controls, and other features.  I only use Safari for testing pages.
0
Mr_FulanoAuthor Commented:
OK...Serialband is correct, there is no Reset option in Safari. I did clean out the cache from the menu dropdown, but that did not solve the problem,

I also upgraded my Adobe Flash, and that did not solve the issue either. I'm still getting the following errors.

-- 4/14/15 7:38:28.038 PM nsurlstoraged[422]: INIT-FAIL: _sqlInsertStmtResponse=0x0, DB=/Users/Fulano/Library/Caches/com.apple.Safari/Cache.db, error-code:11.

** The interesting thing about the error above is that I searched for the "/Users/Fulano/Library/Caches/" folder and it is nonexistent. Perhaps that is why I'm getting the error messages.

I'm also getting the following errors right after the error above.

-- 4/14/15 7:38:28.038 PM nsurlstoraged[422]: writeDBwithCachedResponse-ERROR: task-mgr=Safari-write (_dbWriteConnection=0x7ff71c236360) insert SQL stmnt. is nil for item: https://api.smoot.apple.com/bag?locale=en-US&key=montana4289&sprite=1

-- 4/14/15 7:38:28.038 PM nsurlstoraged[422]: Error: execSQLStatement:onConnection:toCompletionWithRetry - SQL=COMMIT;, error-code=1, error-message=cannot commit - no transaction is active

This is a machine that did not come with Yosemite. It came with Mountain Lion and I've upgraded each time there has been a new upgrade. Could this missing Library folder be a remnant of an older OS?

If so, what configuration file is this line in so I can delete it...or is there another solution?

Thanks,
Fulano
0
strungCommented:
It does not seem right that the cache folder is missing.

In Finder pull down the Go menu to Go To Folder and copy and paste the following line into the search box and hit return:

~/library

If you sort the resultant Finder window by Name, you should find the cache folder.
0
strungCommented:
Once in the cache folder delete the file:

~/Library/Caches/com.apple.Safari
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mr_FulanoAuthor Commented:
Hi Strung....OK, we're making progress. I did find the folder and I deleted all the Cache.db associated files.

I'm no longer getting the error below, so that's good.

OLD error: -- nsurlstoraged[422]: INIT-FAIL: _sqlInsertStmtResponse=0x0, DB=/Users/Fulano/Library/Caches/com.apple.Safari/Cache.db, error-code:11.

The only thing that I see now in the logs is the following message:

4/14/15 8:30:42.609 PM com.apple.WebKit.Plugin.64[2532]: Failed to connect (colorGridView) outlet from (NSApplication) to (NSColorPickerGridView): missing setter or instance variable

and

4/14/15 8:30:42.610 PM com.apple.WebKit.Plugin.64[2532]: Failed to connect (view) outlet from (NSApplication) to (NSColorPickerGridView): missing setter or instance variable

But those are back to the WebKit issue. Perhaps this is not a huge problem. -- I'm going to surf Zillow and eBay a little and see if the reboot occurs now.

Updates to come soon.

Thanks!
Fulano
0
strungCommented:
You will never completely clear out the log of error messages. Many of them are not harmful.

If the problem which prompted your original post recurs, you need to examine the error message from immediately before the occurrence.
0
Mr_FulanoAuthor Commented:
Hi Strung, thus far nothing and I think it would have rebooted by now...so, I think we may have solved it or at least most of it.

I think you put a lot of effort into this, so I'm awarding the points to you. Thank you for your help and if it reboots again, I'll post the error messages right away.

Thanks again,
Fulano
0
Mr_FulanoAuthor Commented:
Excellent advice!!! Very good assistance.
0
strungCommented:
Glad to be of help.
0
Mr_FulanoAuthor Commented:
Hi Strung...no reboots thus far. So, I think we solved it. -- Thanks again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.