Exchange 2010 public folder not updated?

Hi, we have a public folder that showed up all it's contents properly when I accessed my emails from OWA.  However, in Outlook, the public folder contents are not updated.  I've checked each of our database and ensure the public folder is the one we are currently using.
Pls help, thanks.
Soho_DanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeoCommented:
Try this.....Right click on "Public Folders" in Outlook -> Click on the Advanced button -> Advanced tab -> Under cached Exchange mode -> Uncheck "Download Shared Folders"

 Relaunch Outlook. Then, this will make it a standard cached connection instead of a synced connection. See if that does it.
LeoCommented:
if you want to do it from PowerShell console.....issue this command....

Update-PublicFolder "\My Public Folder" -Server "My Server"
Soho_DanAuthor Commented:
I unchecked "download shared folders" and it didn't work.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Md. MojahidCommented:
Most likely you are missing some Outlook updates, check here for the last cumulative patch:

http://blogs.technet.com/b/messaging_with_communications/archive/2013/10/01/current-cumulative-updates-for-office-q4-2013.aspx

Recreate the profile or try in Online mode as next steps
Soho_DanAuthor Commented:
This is not just me.  We have tons of Outlook users and we all have the same problem.
LeoCommented:
have you tried the powershell command on exchange server?
Zacharia KurianAdministrator- Data Center & NetworkCommented:
Could you try turn off cache mode and check?
Is your exchange a complete new installation or a migration?



Zac.
Soho_DanAuthor Commented:
Cannot turn off cache mode. This is setup via group policy.  Exchange is not new.  This problem started when the Exchange server hosting the public folder cannot bootup. We had to change the IP addr and now, the public folder is showing but the content is not the updated one.  Maybe a public folder replication problem?
No, I have not tried the powershell command.
LeoCommented:
Please try it and let me know, I am hoping running this powershell command in exchange will fix issue.

Update-PublicFolder "\My Public Folder" -Server "My Server"
Soho_DanAuthor Commented:
The problem is fixed.  Apparently, the Exchange RPC client access service didn't start after this server was rebooted.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Soho_DanAuthor Commented:
The Exchange RPC service didn't start by itself for whatever reason.  Had to start this service manually and now the Public folder contents are updated.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.