WSUS removing updaes / cleanup

Hello, I just installed WSUS on a server 2008r2 system.  In my original selections it took up over 145gb (English language only).  I have since remove some categories and options and have run the cleanup but it has not yielded any cleanup.

When I go through the cleanup wizard it remove a couple 100 mb.  

Any thought of how to make this cleanup work?

I figure I should only have about 50GB with Windows 7, Office 2010 and Office 2013 updates
tucktechAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Thomas GrassiSystems AdministratorCommented:
I run this weekly

@echo off
del c:\util\cleanup_history.txt

c:\util\wsus_cleanup_cl server10 f 80 superseded expired obsolete compress computers files

Exit


here is the link for the program

http://wsus.codeplex.com/releases/view/17612

this works great
0
Radhakrishnan RSenior Technical LeadCommented:
Hi,

The Server Cleanup Wizard will remove the unneeded files and not touch the still needed files. You may wait for 1 more week and attempt another cleanup and see the size getting reduced.

If none of them helped, delete the content store and reset WSUS using "WSUSutil.exe reset" command. Ofcource,  it will again download whole updates but downloads only whatever been selected.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Nagendra Pratap SinghDesktop Applications SpecialistCommented:
Remove unwanted languages, superseded patches etc in the console. This should trim the DB.

As for the content, delete it and let WSUS redownload it. Sounds a bit extreme but this is the recommended way.

=====================================================
1) Correct any settings above or disapprove any unneeded updates.

2) Close any open WSUS consoles.

3) Go to Administrative Tools – Services and STOP the Update Services service.

4) In Windows Explorer browse to the WSUSContent folder (typically D:\WSUS\WSUSContent or C:\WSUS\WSUSContent)

5) Delete ALL the files and folders in the WSUSContent folder.

6) Go to Administrative Tools – Services and START the Update Services service.

7) Open a command prompt and navigate to the folder: C:\Program Files\Update Services\Tools.

8) Run the command WSUSUtil.exe RESET

http://blogs.technet.com/b/gborger/archive/2009/02/27/what-to-do-when-your-wsuscontent-folder-grows-too-large.aspx

==============================================================================
0
tucktechAuthor Commented:
Hello, I have tried all the solutions EXCEPT the last one from Nagendra Pratap Singh.   I will try this this weekend.  If it does not work, I will remove WSUS and start over...

Thanks,
Tony
0
Thomas GrassiSystems AdministratorCommented:
What type of database you using?
0
tucktechAuthor Commented:
Hello Thomas, I believe it was MS SQL, I just used the default when it installed.

I ended up removing WSUS and changing group policy to use Microsoft's servers.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Seth SimmonsSr. Systems AdministratorCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.