Sharepoint 2013: unable to edit new list app

Hi, all!  Currently running Sharepoint 2013 under Server 2008 R2.  My client is Win7 Pro/64-bit running lastest Firefox, Chrome & IE11.  I am currently a Domain Admin for our corp domain.

Long story short, I've created a test List app.  When I attempt to add a column to the layout of the custom list app, nothing happens when I click the OK button to save the app.  No access spinning, no errors on-screen (also none visible when I view the source of the SP page or header), no nothing.  The highlight of the button changes as expected, but nothing else.  The Cancel button will Cancel as expected, but OK does nothing whatsoever.

My current permissions include member of Domain Admins, Site Owners (Full Control), and Visitors (Read).  A Check Permissions on myself yield the following:

Full Control   | Given through the "~site~ Owners" group.  
Read   | Given through the "~site~ Visitors" group.  
Edit   | Given through the "~site~ Members" group.  

(Note: "~site~" is replacing the actual SP2013 site name above)

I'm thinking it has something to do with effective permissions.  I just added myself to the Owners group this morning with no effect.  I've also tried both Compatibility mode on and off in IE, and Firefox and Chrome don't work, either.  Suggestions are most welcome as I'm at the point where I'm not sure if IE11 is causing a problem or if it's actually an effective permissions problem that's preventing me from saving any column changes to the List app above.

Thanks, guys!
Steve
LVL 2
Steve BottomsSr Network AdminAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rainer JeschorCommented:
Hi Steve,
hm - have you tried using either Chrome`s or IE built-in dev tools, to see if there are any client side script issues AND if at least something is getting sent over the network when the OK button is clicked?
So monitoring both console/script source as well as the network tab.
Just a starting point.

BTW, what do you mean with
"add a column to the layout of the custom list app"? Adding a new column to the list?

Thanks and HTH
Rainer

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
martushaProduct managerCommented:
You can add columns to the list from List settings using Create column link.
Sushanta SahuPrincipal Specialist, Information ManagementCommented:
These issues seems to be completely related to IE11. You should try the same on another computer running IE9 and check. I believe Microsoft also says that IE11 is not supported with SharePoint 2013 so far.

Please let us know how it went.
Steve BottomsSr Network AdminAuthor Commented:
Thanks for the suggestions, guys!

Martusha, as I mentioned in my post, I can go thru the motions to create a new column, but it's the SAVE/OK button that isn't working.

Sushanta, IE11 isn't supported?!?!?!  That's just--- wow.  :)  Makes sense why I'm having odd issues in SP.  I'll try it in another older IE version!

Rainer, that's a great idea to use the built-in Dev tools... hadn't considered it!  I'll definitely give them a look in both IE and Chrome to see if the keypress is even triggering an event in the browser...

I was able to use a combination of SP and SP Designer to get the fields and ordering set up the way I needed it to, so this problem, while still there, isn't an issue for me any longer.  I'll definitely check out the built-in dev tools to see if there's something obvious happening there, but I think I'll close this problem right now and mark it up to an IE compatibility issue.

Thanks, guys!
Steve
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.