External Hard Drive Problem

I'm having trouble with my SEAGATE 2T external hard drive, formatted in exFAT. I am able to copy a folder or a file from, say, C to that external hard drive but then, once the file is there, I cannot delete it or copy it to another drive. When I try, the following error message appears:

Cannot delete <folder or file name> : Cannot find the specified file. Make sure you specify the correct path and file name.

I have other external drives and some work just fine, while one of these other external drives still keeps giving me the same error message. So, I'd like to resolve this problem once and for all. I've tried various suggestions but, unfortunately, I don't even have the Security tab appear upon right-clicking on the drive. I dimly remember that there was something to be done with the registry but have no memory what exactly. Have you any idea how to fix this?
judicoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
I don't even have the Security tab appear upon right-clicking on the drive.

that's because the security tab is for NTFS

have you tried running tests with seatools? perhaps the drive is failing
judicoAuthor Commented:
I'm using Parallels and can see the drive on the Mac side, fully functional. On Windows side I can see the drive in My Computer, can open it and execute the various files in it. It's only when I try to erase or copy files when the problem occurs. In seatools I can't see the drive as I can't see it in cmd.
Michael-BestCommented:
Is it USB 2 or USB 3?
You can get S.M.A.R.T. test results on USB 3
On USB 2 you can check the discs surface.
Use HDDScan a free HDD diagnostic utility
http://hddscan.com/
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

judicoAuthor Commented:
It's a USB 3.0 2T External Hard Drive -- Seagate Backup Plus Portable Drive, Model SRD00F1
judicoAuthor Commented:
I'm trying HDDScan but, again, it doesn't see it. It is seen in My Computer, opens there and the files there are functional, you can open them and execute them. The only thing that can't be done is to erase them or copy them to another drive. On Mac side all this can be done with ease. I guess, then, that it isn't drive's or usb's problem. Something is protecting it on the Windows side that should be removed.
NVITEnd-user supportCommented:
Is exFAT used for compatibility between Mac and Windows?

Does your XP have this hotfix to support exFAT?
http://www.microsoft.com/en-us/download/details.aspx?id=19364
https://support.microsoft.com/en-us/kb/955704
Michael-BestCommented:
What was the S.M.A.R.T. test result with HDDScan ?

If you need?

USB 3 supports tests by SeaTools.

Download and install SeaTools.
Link:
http://www.seagate.com/support/downloads/seatools/seatools-win-master/
judicoAuthor Commented:
@NewVillageIT, indeed, exFAT is used for compatibility between Mac and Windows. It works fine for a transcend HDD as well as for My Passport 2T 3.0 drive. It shows the same problem, however, with a My Passport 1T 3.o drive.

Also, something interesting I just noticed. If I copy a file from C drive onto this problematic drive, everything seems OK. I can open the file, delete it and move it to other drives. It's only when I copy a file from the already mentioned Transcend 128G HDD that the problem occurs.
judicoAuthor Commented:
@Michael-Best, I only did the SeaTools test and, like I said, the drive isn't showing there.
judicoAuthor Commented:
@NewVillageIT, just installed exFAT hotfix but it didn't do any good. Problem persists.
judicoAuthor Commented:
Apparently, the problem is between this drive at hand and the 120G Transcend HDD, which is plugged into the HD slot of the MacBook Pro. That Transcend works very well on both sides (Mac and Windows). For some reason, however, it doesn't jive with the problematic Seagate. I just tried the Transcend drive with the 2T My Passport and everything went very smoothly. If no solution is found I should probably live with this chronic problem and should handle all the transfers from Seagate to Transcend (the other way round I see no problems) on the Mac side. What do you think?
NVITEnd-user supportCommented:
If you can live with that, i.e. Not too painful
NVITEnd-user supportCommented:
Put a post-it reminder
judicoAuthor Commented:
Nevertheless, it bugs me, how can that be that these two drives cannot exchange files freely. It's more of a curiosity. What is it that prevents them from proper communication. Now, when I open the Explorer, the C drive is under the rubric "Hard Disk Drives",  Seagate, together with the A and DVD drives are under "Devices with Removable Storage", while the Transcend drive is under "Network Drives". Has that anything to do with the issue at hand?
Michael-BestCommented:
Something is faulty and if you want to guarantee your safe storage / transference of data then I would test further, even if it requires removing the drive and connecting it another way for  S.M.A.R.T. testing.
judicoAuthor Commented:
@Michael-Best, the HDDScan doesn't recognize the Seagate drive, so the SMART test cannot be performed. Don't know how to make it appear, so that can be tested.  All I see is the C drive. Also, the Transcend SDD (which appears to work perfectly otherwise but not with Seagate) isn't seen there either. Just the C drive.
judicoAuthor Commented:
Transcend is also a SSD drive as the C drive.
Michael-BestCommented:
"HDDScan doesn't recognize the Seagate drive"
???
HDDScan works for SSD
Or you can try SSDLife - freeware version:
http://ssd-life.com/eng/SSDLife-Freeware.html
judicoAuthor Commented:
SSDlife gives this error message:

Sorry, but SSDlife has not detected any SSDs on your computer and will be closed.
Michael-BestCommented:
judico2015-04-15 at 13:11:24ID: 40724355 "Transcend HDD"
judico2015-04-15 at 13:41:51ID: 40724378 "Transcend SDD"
I am confused by this ... do you have an external SDD or HDD ?

I need some away time, so back to your question later.

Regards,
Michael
noxchoGlobal Support CoordinatorCommented:
Maybe the Transcend drive eats too much energy and for Seagate there is not enough power?
You can try formatting this drive as FAT32 or NTFS (for NTFS you would need NTFS for Mac driver http://www.seagate.com/support/downloads/item/ntfs-driver-for-mac-os-master-dl/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
judicoAuthor Commented:
@Michael-Best, Firstly, the Retina MacBook Pro has a 512G SSD of its own. In addition, there is a Transcend  128G SSD inserted into the SD slot. Format of Transcend drive is exFAT so that it can be visible both from the Mac and the Windows side. That drive works very well, despite the fact that SSDlite doesn't detect it.

I'm also attaching the Seagate HDD in question via the USB port, also exFAT formatted to be visible both on Mac and Windows side. Seagate drive also works very well on both sides, except when on Windows side files are copied from the Transcend to the Seagate. Once the files are copied onto the Seagate they can no more be deleted or copied onto any other drive.  Interestingly, files copied (on Windows side) from C to Seagate have no such problem.

This problem is only on the Windows side. On Mac side Transcend-Seagate interaction is seamless -- files can be copied in both directions and can be deleted on each drive.
judicoAuthor Commented:
@noxcho, I need Seagate to be visible on both sides -- Mac side and Windows side. So, NTFC won't do. I need exFAT for that reason. Tried it, just as an experiment, with FAT32 but the problem remained. As for the power, both Transcend and Seagate work very well on the Mac side. It's the Windows side where the files copied onto Seagate from Transcend that get suddenly locked for some reason. Files copied from C to Seagate (on Windows side) do not have this problem.
judicoAuthor Commented:
Tried it again. The transfer in the direction Transcend -> Seagate locks the folders for some reason on Windows side and once these folders are copied onto Seagate they can't be deleted. On Mac side that problem doesn't exist. Also, individual files copied in the direction Transcend -> Seagate (on Windows side) seem OK. They can be deleted from Seagate both on Windows and on Mac side.
noxchoGlobal Support CoordinatorCommented:
Mac side and Windows side - they both see NTFS. By default. The only limitation is that on Mac side you can only read from it.
But with the NTFS for Mac driver - you can write and read to/from that drive.
judicoAuthor Commented:
@noxcho, I installed Windows NT filesystem and reformatted the Seagate. Indeed, both sides see the drive, read and write is available on both sides. However, the problem, described above, persists.
noxchoGlobal Support CoordinatorCommented:
So the problem is not in the drive but in permissions then.
judicoAuthor Commented:
@noxcho, that's my feeling too. How do you change the permissions, though?
judicoAuthor Commented:
Here's another observation. If a folder is copied from Transcend onto Seagate on the Mac side, that same folder can be deleted from the Windows side. So, Transcend isn't placing restrictions on the folders when handling them on the Mac side. Apparently, the permission problem is solely Windows problem.
judicoAuthor Commented:
What I'm finding out further is that, while in My Computer right-clicking on the drive doesn't amount to much, as I said, right-clicking on the shortcut icon of the drive already shows up the Security and other tabs. Upon inspection, it appears that both Transcend and Seagate have the same parameters and allowances checked under any tab.

Permissions are set to Administrator, Administrators (plural) and SYSTEM, as are for C drive as well.

Next thing I found out. While the folder copied from Transcend to Seagate cannot be deleted from Seagate once there, if the files in this folder are deleted, then the folder can also be deleted. Somehow Transcend places a restriction on the folder containing files. What do you think about this? I thought there may be something in the registry that may be changed to fix this.
judicoAuthor Commented:
I guess, no more can be said on this problem. It has been solved to a certain extent but not entirely. So, every one of the three experts deserves points for pointing out different aspects that may concern this question. Therefore, I'd like to give them equal number of points for the participation.
judicoAuthor Commented:
I'm awarding these point mainly for the participation and for suggesting some useful tips regarding the permissions. Unfortunately, the problem couldn't be solved conclusively but that may be due to subtleties beyond the reach of experts outside of the production facilities. Thanks for the help.
Michael-BestCommented:
Although you have closed.
I found some helpful reading about Permission Issues on an External Drive from knowledge.seagate.com

Link:
http://knowledge.seagate.com/articles/en_US/FAQ/203795en
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Hardware

From novice to tech pro — start learning today.