We help IT Professionals succeed at work.

Windows Server 2012 R2 DHCP Server Bindings Not listing NIC's

4,957 Views
Last Modified: 2015-04-16
Hi All,

Simple question, can't figure out the answer and am looking for the easy way (ask you all).

I have a Windows Server Standard 2012 R2 Server, I had to remove the NIC's (removed the drivers as well) and replaced them, long story don't want to get into that.  I have now the IP's to static but when I go into the DHCP Manager, it shows it is running but it is not binded to any IP's....

I go to Add/Remove Bindings and nothing is listed....

How can I get the newly setup IP's as binded in DHCP????
Comment
Watch Question

Author

Commented:
OHH and I REALLY don't want to have to uninstall/reinstall or unconfigure/reconfigure DHCP, that is WORSE case scenario.

Thanks again
Zacharia KurianAdministrator- Data Center & Network

Commented:
are you sure that you assigned the same old IP?

Zac
Dan McFaddenTechnical Lead - Active Directory
CERTIFIED EXPERT

Commented:
DHCP will use the first statically configured binding it finds.  Can you post an ipconfig of the DHCP server?

Dan

Author

Commented:
Here is ipconfig /all on the server, removed some key names:


Windows IP Configuration

   Host Name . . . . . . . . . . . . : <HOST>
   Primary Dns Suffix  . . . . . . . : <COOLSITE>.com
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : <COOLSITE>.com

Ethernet adapter Ethernet 7:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) I350 Gigabit Network Connection #3
   Physical Address. . . . . . . . . : 00-1E-67-CF-C0-12
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.2.11(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Ethernet 6:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Ethernet Converged Network Adapter X540-T2 #2
   Physical Address. . . . . . . . . : A0-36-9F-3A-B4-F4
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.1.11(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Ethernet 5:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Ethernet Converged Network Adapter X540-T2
   Physical Address. . . . . . . . . : A0-36-9F-3A-B4-F6
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{A1F7E3A5-CA7A-48E8-A13A-525C6DB6CB9A}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{658F7DF8-1A41-4270-8CF9-66DEE97D1E85}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{7E324E9E-A65C-4781-85C0-36C59AEFB036}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Also I am SURE I am using the same IP's.

Note: Prior in Windows 2008 R2 I used: dnscmd . /ResetListenAddresses 192.168.1.11

and that worked, not helping now in this case (I also have DNS setup on this server)
Technical Lead - Active Directory
CERTIFIED EXPERT
Commented:
This problem has been solved!
(Unlock this solution with a 7-day Free Trial)
UNLOCK SOLUTION

Author

Commented:
ok back to DHCP, ugh I missed it!!!!

OK Note that the NIC's are connected to a switch with nothing else on them....

I am setting a static IP via windows but as soon as I am done setting the IP and I check again the IP shows DHCP?!?!

Trying to figure that out....
Dan McFaddenTechnical Lead - Active Directory
CERTIFIED EXPERT

Commented:
Are you a local admin on the server?  Try disconnecting the DHCP from the network (all connections).  restart the server, and try to change the settings again.

Dan

Author

Commented:
ok... so

For the 192.168.1.11 IP I was able to set it via netsh, when I run ipconfig /all I see that DHCP is off.

But when I go through the Network and Sharing Center to manually check, it shows that it is set to DHCP with no IP?!?!

Going to uninstall/reinstall the driver.

Author

Commented:
the image was having issues with stored ip's in the registry.  ended up just going back to a previous image.

Author

Commented:
lead to the final decision