Cisco Switch

In a switch configuration , fa0/3-4 are configured with trunk and lacp link aggregation.

what's the "interface Port-channel 1" ? Does it create when we issue the "channel-group 1 mode passive" ?

Can it configure fa0/3-4 with the following configuration, without touching the channel-group interface ? Any difference for these two configuration ? Tks

Advised configuration on fa0/3-4
-----------------------------------------------
channel-protocol lacp
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,21-23
channel-group 1 mode passive
switchport mode trunk


current configuration
------------------------------
!
interface FastEthernet0/3
switchport trunk allowed vlan 1,21-23
channel-protocol lacp
channel-group 1 mode passive
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk allowed vlan 1,21-23
channel-protocol lacp
channel-group 1 mode passive
switchport mode trunk
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
spanning-tree allowed vlans 1,21-23
!
Switch-Configuration.txt
AXISHKAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Don JohnstonInstructorCommented:
The port channel interface is automatically created when you issue the channel-group command. It is the virtual interface that the physical interfaces are associated with.

Once the channel is successfully created and functional,  most configuration commands can be issued on the port-channel interface and will then appear on all the physical interfaces associated with that port-channel interface.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.