Cannot remote desktop my domain controller after windows updates

Hello,

Today I applied the updates on our domain controller. We are using small business server 2003 for it.
After I rebooted i couldn't connect anymore using remote desktop from my computer (and others I tried too). I just checked again, there are authorization to connect using remote desktop connection.
I get the following error message right after trying :
The computer can't connect to the remote computer.
Try connecting again. If the problem continues, contact the owner of the computer or your network administrator.

Open in new window


I have no idea what happened, aynone has any?
vanroybelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

vanroybelAuthor Commented:
I can still connect to other servers on the network.
I tried rebooting my computer to see if it was an authentication problem but it didn't change anything.
0
kola12Commented:
Check Windows Firewall settings on DC. Maybe update turns on firewall...
0
vanroybelAuthor Commented:
I checked, the firewall wasn't accessible because the ICS was off. After checking the firewall and selecting remote desktop in it I can see that the port TCP 3389 is open.
I still can't connect after that, I get the same error message.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

kola12Commented:
Can You chack all network settings (ip, Gateway etc.)?
Can You rollback updates that you installed? Then install updates one by one and check witchone doing problem.
0
Harper McDonaldCommented:
Did you apply the updates via a RDP session and reboot or did you install locally on the server?  Is RDP enables still after the updates?
0
vanroybelAuthor Commented:
Kola12 :
This our domain controller and exchange server, I cannot reboot it often. I will try anything else before uninstalling the updates and then trying to install them one by one. I'm not sure anymore because I did a lot of updates but I think there was at least 10 updates, that means rebooting 10 times and that is way too much.

Harper :
I did it via remote desktop connection and it is still activated, I checked on the server. My use is still authorized to connect to the server.
0
vanroybelAuthor Commented:
kola12 :
I also checked the network settings and everything is as usual for that.
0
vanroybelAuthor Commented:
Hello,

So i've been looking  at the situation and it seems I'm missing some services. When I look at the services list, I cannot find remote desktop service. It seems it has disappeared. When I check on my windows seven computer, this service is there.

Is it another name in SBS2K3? Or maybe that is my problem, if I don't have the service active on my server, I won't be able to use remote desktop connection with it.

Thanks.
0
vanroybelAuthor Commented:
So I checked the registry, the port number for remote desktop is still 3389. When I use netstat -no, I don't see anything using port 3389. So it seems that remote desktop in not started.
How can I force it to start? Do I have to reinstall something?

Thanks.
0
vanroybelAuthor Commented:
So, finally it's ok.
The problem was far from urgent and I had a lot of other things to do.
I checked quite a few things, and finally I had time to do a reboot (main domain controller, I may not reboot it when I want).
The problem was solved after a reboot.
I think the service crashed at the previous reboot, and it had nothing to do with updates. I think I was unucky.

I don't really have a solution, and I can't really accept the solution of anyone who answered.
I think the question should be deleted since it is not something that will help anyone else.
0
vanroybelAuthor Commented:
To conclude :
My problem had nothing to do with the updates it seems.
I searched on the web and found someone saying I should try to use netstat -no and find the process with the port 3389. I didn't find that process. Then I checked the port number for remote desktop in the registry, in the key HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Control, Terminal Server, WinStations and RDP-Tcp, PortNumber dword. The port was 3389.
Then I didn't have time to take care of this problem anymore for a week.
When I came back I decided I would try another reboot, in case something else was the problem.
After the reboot, everything worked correctly.
I then verified the same things to see if anything changed.

I still can't find a process with the port 3389 when I do netstat -no. The port is still the same in the registry. The service for this is "Terminal services" and it is active on the computer. I didn't know which service was responsible for remote desktop connection before, and I tried to search for the service beginning with remote something and didn't find it so I thought the service wasn't active anymore. If I knew it was "terminal services" maybe I just had to restart that services and it would have worked.
I'll know for next time.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vanroybelAuthor Commented:
Thanks Kola and Harper for your suggestions, but as it was not the right direction for the solution it's a bit hard to justify accepting your comments as solutions. So I created a comment with all the steps I used to solve my problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.