Exchange 2010 services not starting after creating second server with same name

We have an Exchange '10 Server called EXCH10.  In preparation for migrating to Exchange '13, I created a new VM, intended to be called EXCH13.  I joined it to the domain and then realized that I had mistakenly named it EXCH10 as well.  I changed its name to EXCH13 and that's where I left it for the day.

A few hours later, I was notified that users couldn't connect to Exchange.  I connected to EXCH10 but couldn't log in--I got a trust relationship error.  I logged in as the local administrator account and found that the Exchange Transport Service wasn't running.  I removed the server from the domain, rebooted, and then readded it.  (The removal and readding processes each took close to 10 minutes after I entered the domain credentials.)  After the reboot, about half of the Exchange services wouldn't start.  

I removed EXCH10 and EXCH13 from the domain again and "reset" their accounts in ADUC.  I then joined them back to the domain.  That had no effect--the same services won't start.  I'm guessing that something is messed up with the SID but am not sure what to do next.  Please advise.
LVL 1
SINC_dmackAsked:
Who is Participating?
 
SINC_dmackAuthor Commented:
Browsing through the event log, I found:  

Microsoft Exchange System Attendant does not have sufficient rights to read Exchange configuration objects in Active Directory. Wait for replication to complete and then check to make sure that the computer account is a member of the "Exchange Servers" and "Exchange Install Domain Servers" security groups.

I made the computer account for EXCH10 a member of Exchange Servers and Exchange Install Domain Servers.

Process MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=1224). Topology discovery failed, error 0x80040a02 (DSC_E_NO_SUITABLE_CDC). Look up the Lightweight Directory Access Protocol (LDAP) error code specified in the event description. To do this, use Microsoft Knowledge Base article 218185, "Microsoft LDAP Error Codes." Use the information in that article to learn more about the cause and resolution to this error. Use the Ping or PathPing command-line tools to test network connectivity to local domain controllers.

I Googled the latter error and found this article:  http://blogs.msdn.com/b/keithmg/archive/2009/01/06/exchange-topology-discovery-failed-error-0x80040a02-dsc-e-no-suitable-cdc.aspx  It states: Goto Active directory on your domain Controller and add your exchange server as a 'Computer' on the 'Domain Admins Group'.  I'm not sure exactly what he meant, so I made EXCH10 a member of the Domain Admins group.  

After a reboot.. all of the services appear to be running!!
0
 
SINC_dmackAuthor Commented:
Other notes: there is an Exchange '03 server on the network that is in the process of being decommissioned.  All of the mailboxes have been moved off of it and it is no longer routing mail--basically it's just waiting to be uninstalled.  I noticed that when EXCH10 is shutting down, it hangs for a while at "shutting down Exchange replication service".  It didn't used to do it, and I'm not sure if it's significant.  

I have a backup of the domain controller and EXCH10 from two nights ago.  Can I back up the mailbox store from EXCH10, then restore the DC and EXCH10 to pre-broken status, and then import the mailbox store?  (There is no other data being stored on the DC or EXCH10, so as long as I can save the mailbox store, I should hopefully be safe overwriting them.)
0
 
SINC_dmackAuthor Commented:
The other thing I was considering was removing EXCH10 from the domain, deleting its computer object in ADUC, and then joining it back to the domain so that the account is recreated.  I've done that in the past with workstations with no problems, but I'm not sure what the ramifications would be of deleting an Exchange-enabled computer account.

The Application Log is riddled with Exchange-related Active Directory authentication errors.
0
 
SINC_dmackAuthor Commented:
I sent some test emails via OWA and they got hung in the drafts folder.  I did some research and found an article talking about it being a SID issue.  However, none of the devices should be sharing SIDs--each VM was created from scratch--so I disregarded it.  

I ran the Exchange BPA and it threw an error about EXCH10 not being a member of Exchange Trusted Subsystem group, so I added it to that group.  I then restarted the Exchange Submission service.  After doing so, OWA emails seem to be delivered immediately, rather than being hung up in the Drafts folder.
0
 
SINC_dmackAuthor Commented:
Solved it by myself.  (If "by myself" can include extensive Googling.)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.