followed this for setting up ftp server on iis. But fails thru VPN. What to do?

Hi;

I followed this link for setting up ftp server on iis for anonymous authentication.

http://www.iis.net/learn/publish/using-the-ftp-service/configuring-ftp-firewall-settings-in-iis-7

This works fine without any VPN but once the target machine is under cisco anyconnect VPN, i receive ftp connection timeout due to inactivity VPN in filezilla client.

So, is it the firewall settings or is it VPN server settings that needs to be handled?
LVL 12
jazzIIIloveAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
FTP server on IIS for anonymous authentication.

Check to make sure Active / Passive FTP is set up correctly.

http://slacksite.com/other/ftp.html
Dan McFaddenSystems EngineerCommented:
What VPN client are you using?  Is your VPN client pushing some sort of policy that forces firewalling or application blocking to be enabled?

Dan
jazzIIIloveAuthor Commented:
Hi,

I didn't do anything about passive mode as it sounds it needs extra ports other than 21. Am i right?

I am using cisco anyconnect mobile client. I don't know whether there is a setting or not regarding your question but isn't such policies getting setup on VPN server end? How can i know about those? I have no access/control on the VPN server.

Br.
Dan McFaddenSystems EngineerCommented:
First off... FTP is defined with 2 TCP ports.  20 & 21.  Passive FTP just means that after establishing a valid connection, the client & server will negotiate continuing the session on other higher tcp ports.

Active means the sessions stay on ports 20 & 21.

If you don't have control over the vpn server, I suggest you speak with the admins that do manage it, to find out what happens during a VPN session.

Dan

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnBusiness Consultant (Owner)Commented:
@jazzIIIlove  - Thanks and I was happy to assist.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.