IE ii will not add search engines from Internet Explore Gallery - probable Java issue

I have tried this on a number of systems and I cannot get any of the add-ons (for searches) to install from Microsoft's Internet Explorer Gallery.  The "Add to Internet Explorer" button does nothing.  I am thinking this is a Java problem.  In addition, historically if I go to https://www.google.com a little tool bar will pop up asking me if I want to install google search as my primary engine.  This too has stopped.  Any suggestions?

The search engine  is here:  http://www.iegallery.com/en-us/Addons/Details/813

It will not even work with IE as an administrator
Marshall KassOwnerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jcimarronCommented:
Marshalk --
Are you using the procedure described here under "To add new Search providers"?
http://windows.microsoft.com/en-us/windows/change-choose-internet-explorer-search-provider#1TC=windows-7

If you did and you still have the problem:
Repair IE FixIt.  I suspect this is an add-on problem.
https://support.microsoft.com/en-us/mats/ie_performance_and_safety

Reset IE
http://windows.microsoft.com/en-us/internet-explorer/reset-ie-settings#ie=ie-11-win-7

http://windows.microsoft.com/en-us/windows7/Reset-Internet-Explorer-settings

And if still no help:
Uninstall/reinstall IE
http://windows.microsoft.com/en-us/internet-explorer/install-ie#ie=ie-11-win-7

Sometime you can fix IE by using Control Panel|Programs and Features|"Turn Windows Features on or off" .  Uncheck IE|OK  When finished you have to reboot.   Then go back to "Turn Windows Features on or off" and check the IE box.  When finished you have to reboot again.
Marshall KassOwnerAuthor Commented:
I have actually tried all the above.  I also tried it on 3 different PCs running WIN7 with either IE10 or 11 and had the same results on all of them.  I believe that it is actually either a Java issue or an issue with the website as it will not load ANY of the search engines on any of the PCs I tried (on domain, off domain, in my office and off-site)  

Turned off pop-up blockers, reset, uninstalled and reinstalled, etc...

three of the PCs I tried already have Google as the default search engine, I just wanted the pop-up to appear and I would have backed out.  Try it as let me know if you experience the same thing please.
jcimarronCommented:
Marshalk--
No, I do not have the same problem.  
It is kind of strange that this is happening on three PC's.  What do they have in common?
Has this started recently?  If so try a System Restore.
Have you tried uninstalling and reinstalling Java?  Java offers an Uninstaller Tool
http://www.java.com/en/download/faq/uninstaller_toolinfo.xml
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Marshall KassOwnerAuthor Commented:
All the PCs that I have tried are all different.  Built at different times, different locations, different versions of IE and yes, I have tried reinstalling Java (8.45 and 8.25 & 7.45 - tried them all on two of these test PCs)
System restore isn't a viable option as the PC I originally ran into this issue was JUST rebuilt, the other PCs do not have any other issues except they all fail at the Internet Explorer Gallery.
Marshall KassOwnerAuthor Commented:
were you able to load the search engines from the MSFT website?
Marshall KassOwnerAuthor Commented:
jcimarronCommented:
Marshalk--
Some will load and some will not.  For example, Wikipedia Visual Search will not.  Bing will.

Try this address for the Gallery.
http://www.iegallery.com/en-us/addons?callback=true&featuretype=2
Marshall KassOwnerAuthor Commented:
nope - doesn't work.  I see the link at the bottom of the page, get the "pointer" finger, but nothing happens when I click on the link.  Same as my link
Marshall KassOwnerAuthor Commented:
I have to run, but I will revisit this tomorrow.  Thank you for your time, I really appreciate it and your assistance.
jcimarronCommented:
Marshalk--
What search engine do you want to add?  I suspect there will be another way.
Marshall KassOwnerAuthor Commented:
Google's
jcimarronCommented:
Marshalk--
So you want to make Google a Search Engine option?  If nothing else works, as a workaround go to https://www.google.com/
and with the left mouse button drag the little Google icon at the left of the Address line down to the Task Bar.  Or you could make a Favorite out of https://www.google.com/

I am curious.  I assume you have an Address bar near the top of your IE screen.  Can you search for anything when you enter appropriate search terms and click Enter.  Or do you have no search capabilities at all?  If you click the little down caret/arrow at the end of the Address bar do you see the icons for any search engine at the bottom left of the drop down window?  Those are the Search engines already installed.  You choose the engine you want to use by clicking its icon.
jcimarronCommented:
Marshalk----
You seem to think this is a Java problem.  But rather than Java, maybe it is a JavaScript problem.  Maybe yours is disabled.

IE Tools Internet Options|Security tab|highlight Internet zone|Custom Level| Scripting section.
Under Active Scripting select "Enable".
If you get a Warning asking "Are you sure you want to change the settings for this zone?" select "Yes".
OK out
Refresh the browser window.
Marshall KassOwnerAuthor Commented:
I have Google as the default search engine on my pc.  If I go to the MSFT IE Gallery website and click on the Google search engine I should get either a pop-up saying it is already installed or asking me to update it.  On the PCs I was originally having this issue with, Bing is the only engine as they (now 3) were all new installs.  This is the way I have been doing it for years.  I did a work around making Google the homepage, but this is something entirely different.

My JavaScript is enabled on all the PCs I have tried.  It seems to be affecting computers using Java 8+.  It shows the java script at the status bar on the page, but the buttons or pictures (showing the links) do nothing when clicked on.
Marshall KassOwnerAuthor Commented:
Marshall KassOwnerAuthor Commented:
BTW - thank you for all the time you are giving me!
jcimarronCommented:
Marshalk--
What is the browser you are using in the first screenshot you posted?  It is not IE11.
If it is Chrome, the iegallery.com Add-ons do not work for me, either when I use Chrome.  But if you follow this path in Chrome
Click the Menu button (three horizontal lines at to top right)|Settings you should be able to set a Search engine from that menu.

You also can check to see if javascript is enabled in Chrome
https://support.google.com/adsense/answer/12654?hl=en

You are welcome for the time.  I just wish I could help your problem.
Marshall KassOwnerAuthor Commented:
Internet Explorer 10.  I tried different versions same issue
jcimarronCommented:
Marshalk--Your last post crossed my last post.
Have you tried IE11?
Try Resetting IE.  IE Tools|Internet Options|Advanced tab|Reset

Also see my other comments in the last post.
Marshall KassOwnerAuthor Commented:
Tried IE 9, 10 & 11 on new installs, old install, working PCs....  However the good news is that I can recreate the problem as often as I like.  :-)
jcimarronCommented:
Marshalk--
The really weird thing is that this is happening on three or four different PC's.  What do they have in common?

To test if Java is the culprit, uninstall.  Then try working on the iegallery.com when you have uninstalled Java.
http://www.java.com/en/download/faq/uninstaller_toolinfo.xml
http://java.com/en/download/manual.jsp   Beware if Java offers other piggy back downloads.

Did you reset IE?

I agree that the website could share some of the guilt here.  Note it does not work for me using Chrome.  That could be because of some coding.

I will be out for a few days starting at the end of today, so will not be able to respond until perhaps next week.
Marshall KassOwnerAuthor Commented:
Resetting was first thing I did, 2nd was uninstalling JAVA.  On brand new builds.  Have a good time, speak with you when you return.
jcimarronCommented:
Marshalk--
Remember "I agree that the website could share some of the guilt here"  And some of the buttons do not work for me, either.
Are you trying in Internet Explorer?
Regret that I have run out of ideas, except that I just went back to gallery many more of the add-ons seem to work now. But not Google.
Marshall KassOwnerAuthor Commented:
Yeah, I think it's a Java / MSFT thing.  It is amazing to me that these two companies will not only mess with each other, and by extension, millions of people, but that there is NO way to get any assistance or even notify them of the issues.

And we complain about lawyers...

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Marshall KassOwnerAuthor Commented:
This issue has been resolved (it all of a sudden started working again, without any additional adjustments by me.  I think it was a website based error.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java

From novice to tech pro — start learning today.