Cant copy big files between VMs unless disable "auto tuning feature” in vnic

We encountered problem while enabling the alwaysOn availability:
We could copy smaller files (generally <900MB) but copying files (these are MS SQL backup files )
>1GB  will drop/freeze between the two VMs running MS SQL 2012.

We overcame this by disabling 'auto-tuning feature' :
“netsh int tcp set global autotuninglevel=disabled”

Q1:
What's the implication/impact of disabling auto-tuning?

Q2:
What's the root cause that the copying freeze/drops for files >1GB ?
Is there a VMware or MS KB article for this?


We're on vSphere 5.0 Upd 3  & the VMs are on Win2012 (not sure if it's Standard or DC edition)
sunhuxAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Are you using the VMXNET3 interface in all your VMs, you should be.
0
sunhuxAuthor Commented:
Yes, we are.  Missed replying on this thread though replied on the other one
0
AkinsdNetwork AdministratorCommented:
See the comments from Microsoft Below.
https://support.microsoft.com/en-us/kb/947239/en-us

If you enable Receive Window Auto-Tuning for WinHTTP traffic, data transfers over the network may be more efficient. However, in some cases you might experience slower data transfers or loss of connectivity if your network uses an older router and firewall that does not support this feature. For example, when you use Windows Internet Explorer to access applications that are hosted in Microsoft Office SharePoint Server, the HTTP traffic may slow down. This occurs because certain routers do not support the Receive Window Auto-Tuning feature.
In your case, this means the vSwitch on your VM Host does not support auto-tuning or it's turned off.

Q1:
What's the implication/impact of disabling auto-tuning?

A1
Just means you lose the additional benefits of auto-tuning which is mainly TCP Receive Window feature. In this case, you're much better off without it than with it.
See
https://technet.microsoft.com/en-us/magazine/2007.01.cableguy.aspx


Q2:
What's the root cause that the copying freeze/drops for files >1GB ?
Is there a VMware or MS KB article for this?

A2:
Slow speed due to incompatibility. The computer uses more CPU power trying to use the TCP Receive Window feature and then falling back to normal operation
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.