Unable to modify web.config using WebDAV

Hello,
We have been struggling with an issue with the ability to upload the web.config to IIS 7.5 via WebDAV.  When we try to upload using Windows Explorer client, we get an error stating "The parameter is incorrect." (attached).  Using other clients, like BitKinex yields a similar error ("HTTP/1.1 401 Unauthorized" or "HTTP/1.1 400 Bad Request")  We are able to modify all of the other files within the directory but not the web.config.  Any help is much appreciated.  Thanks!
BlueJackITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dan McFaddenSystems EngineerCommented:
Have you checked your authoring rules for the WebDAV setup?

This could also be an NTFS permissions issue since the web.config file is a protected asset.  Make sure the user account that is being used to update the file has modify permissions (RWD).

reference link:

- http://www.dotnetscraps.com/dotnetscraps/post/did-you-know-configure-webdav-in-iis-7-75.aspx

Dan
0
BlueJackITAuthor Commented:
Hello,
The account has the necessary permission to make the change.  Still not functioning though.
0
BlueJackITAuthor Commented:
Update: I have found the parameter within the web.config that was causing the issue.  The following parameter:
<jsonSerialization maxJsonLength="1000000000" />

is not allowing the web.config to be updated.  Once we removed it, we are able to upload the file.  Now we need to find somewhere outside of the web.config where we can place this parameter.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BlueJackITAuthor Commented:
We ended up placing the parameter in the machine.config.
0
BlueJackITAuthor Commented:
I ended up solving this on my own.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.