Unified Messaging (Exchange 2010) with Lync 2013 - Voicemail and Auto Attendant problems

Unified Messaging is all set up (followed several tutorials, the most helpful one being this one: http://blog.schertz.name/2010/11/lync-and-exchange-um-integration).

When I first dialed our Auto Attendant, it would ask for me to speak a name or dial an extension. The name always failed so I tried to dial an extension. It attempts but ultimately also fails. I now have it configured to only let you dial an extension and when you attempt that, it says "The call cannot be transferred. Returning to main menu." twice before silence.

Voicemail also won't call my phone to let me record a message, either. When I click "Call the Play on Phone number to play or record a greeting for this call answering rule...", if I accept the default value ("user@domain") it just appears to time out. If I dial my extension, I get "The number cannot be dialed because it does not comply with the policy of your organization".

I've read to disable REFER support for the first problem and to check the "Enable dialing of extensions" (or similar) for the second but neither worked.
street9009IT Project ManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohammed HamadaSenior IT ConsultantCommented:
Any errors on Lync or Exchange event viewer ? Have you configured a certificate on Exchange that's generated from the same CA that Lync FE has? it most of the time is a Certificate issue.

Try running a trace on Lync to see what it results. use Lync debugger tool for that.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
street9009IT Project ManagerAuthor Commented:
Sorry for the holdup on this. Ran into trouble with our SIP provider and am still working through it.

I installed the Lync Server 2013 Debugging Tools but I can't figure out how to use (I don't even see a shortcut anywhere to open). Can you help me there?
Mohammed HamadaSenior IT ConsultantCommented:
The debugger tool location is usually "C:\Program Files\Microsoft Lync Server 2013\Debugging Tools"  
when you run the tool you should select some particular components that pertains to the setup you're going to troubleshoot which is "UM".

When you open it, Make sure you select the current components and in everyone of them select all the flags  listed there and "ALL flags" as well.

ExumRouting
MediationServer
InboundRouting
OutboundRouting
S4
SipStack
UserServices

Under Log file options select "New File" and change the file size to 100 MB.

Start logging right before you start a test call to test Voice Mail and AA.  When you finish the testing calls. you may stop  logging and then click on "Analyze log files". that should launch snooper tool.

You can look there for the errors and warnings. or you can upload the file here so I can look at it as well.
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

street9009IT Project ManagerAuthor Commented:
I am still having trouble with our SIP provider but as soon as we have gotten through the issues (or changed providers), I will come back to this. I apologize for the delay.
street9009IT Project ManagerAuthor Commented:
Okay, all of the issues are resolved with our SIP provider for now. I have gone through and performed the logging process and the logs are attached. The first log is from where I dialed the automated attendant. It correctly picked up my name when I spoke it (which wasn't happening before) but it still can't transfer the call. The second log is from where I logged in to set up my voicemail (which took me to our mail server in a web browser) and when I tell it to call me, it says "Dialing..." for a few minutes and then changes back to "Call".
OCSLogger-2015-05-15-15-18.txt
OCSLogger-2015-05-15-15-23.txt
street9009IT Project ManagerAuthor Commented:
It was a certificate issue. I had given UM the existing exchange certificate which wasn't for the proper server name. Generated a self-signed one for the proper name and most of the functions fired up.
Mohammed HamadaSenior IT ConsultantCommented:
Good news street9009, glad to hear that it's solved.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.