Exchange Management Console

I have a 2010 Exchange Server Running on a 2012 Server.   When opening the management Console I get the following error:  see attached clip
Tim DawsonIT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BrandonProject Manager, IT Systems and Software DesignCommented:
Don't see anything attached.
0
Tim DawsonIT ManagerAuthor Commented:
Sorry forgot to upload.
Console-Error.jpg
0
BrandonProject Manager, IT Systems and Software DesignCommented:
Did you happened to update or install a new cert?  I found this happened when I did this and did not restart the machine.

Either way, try doing a IISRESET on the server. If that does not work you should restart the server if you have not. But the IISRESET fixed my previous issue.

Let me know...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Tim DawsonIT ManagerAuthor Commented:
I'll restart tonight, and let you know.  Thanks
0
BrandonProject Manager, IT Systems and Software DesignCommented:
you can try the iisreset first. this usually fixes it without a full restart.
0
Tim DawsonIT ManagerAuthor Commented:
Ok,  well I need to do Win updates anyway.
0
Tim DawsonIT ManagerAuthor Commented:
Installed updates and restarted.  All good now.  Thank You !!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.