• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 336
  • Last Modified:

2008 SBS Complete PC Restore FAILED...

Oh boy... where do I start...
Running a 2008 SBS, after 122 windows updates, it would not boot back up properly, hanging at the 'Configuring Updates Stage 3 of 3' but never getting past the 0% mark. After 2+ hours, I gave up, researched that problem & found renaming an .xml file in the winxs folder (sorry, if I'm off on the exact names. it's been a long & trying day!) & after that, it started all over with the problem of being stuck in the 'applying computer settings' stage (that I waited over 2 hrs for, before getting to the 'configuring updates' stage!). At that point, I figured I'd cut my losses & restore from a backup (windows backup, saving to a 1.5TB Seagate external USB drive), as I've done in the past. I have 2 mirrored arrays in this server (have checked via controller utility that arrays are ok) & since all my data, mailboxes, etc., I am only wanting to restore the C drive, I'm choosing only restore system disks . Booting from install DVD, going to repair computer, choosing complete PC restore. The first time I tried this, I picked the most recent backup, it went through all the motions & when progress bar was just about complete, got the message that it failed & under error details I get 'Catastrophic failure (0x8000FFFF). Give it another try, picking the next oldest date & once again, it fails, this time with the message 'The file or directory is corrupted and unreadable (0x80070570). Any subsequent tries & I am not seeing my OS listed - do I need to wipe & reformat array? Do I need to load drivers? Can I do anything to this backup from another computer, to check it or get it to a state I can use?
HELP!
0
gromack
Asked:
gromack
  • 8
  • 4
  • 2
  • +2
3 Solutions
 
gromackAuthor Commented:
Or, if I was to wipe my disks, reinstall a fresh copy of sbs 2008, could I go to my back up & restore from that?
0
 
David AtkinTechnical DirectorCommented:
Do you have another backup on another backup drive?  - Even if its slightly older.

Try doing a restore to a virtual machine using the backup that you have - See if you get the same error.  Yes it will be time consuming but its better to try before you wipe anything!  At the moment it isn't clear if you're backup is clean so you don't want to risk data loss.

I'd consider running a chkdsk on the backup drive.

Does your server have a built in memory test?
0
 
Davis McCarnOwnerCommented:
A lot of hits on your 0x80070570 error say to cancel then redo the restore without rebooting which then works the second time.  It sounds like your now past that......
Try these ideas: https://social.technet.microsoft.com/Forums/windowsserver/en-US/0e6a7b6a-70de-41af-b2c8-5f8f3c86cef7/bootmgr-is-missing-in-windows-server-2008-r2
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
gromackAuthor Commented:
At this point, I am running chkdsk, its on 111511 of 219312, but still says its at 11% (been running for 2 & a half hours), but the dell people say let it run, then run it again to see that it comes back error free.
What I'm afraid of is the chkdsk taking another few hours & then still not booting!

I did try the next older backup way back in the beginning, but got the message 'the file or directory is corrupted and unreadable'...
0
 
David AtkinTechnical DirectorCommented:
Was the old backup on the same drive?

Yes let the chkdsk run and complete.  It may take some time but ultimately you need to allow it to complete.

If it completes (and says error free) then I would try the restore again - As DavisMcCarn suggests, if it errors the first time then try the restore again without a reboot.  Failing that, try a restore to a VM on another PC.

Do you monitor the backup reports - If so, where there any warnings or did they complete ok?

Things you can do in the interim:
 
If email is essential then create temp pop accounts on another server and redirect the MX records - This way the client can at least get new emails.  You will have to import them once the server is back online though.

Start the Server (as it is) and run an sfc scannow from command prompt.  You will need your SBS CD - Its under repair my computer option.

Run a memory test on the server.
0
 
gromackAuthor Commented:
Yes, older backups are on the same drive. I check the logs from time to time & saw no problems with the backups.
I'm past 4 hrs running chkdsk, but at this point I'm in for the long haul, so it's running till its done.
What do I need to set up a virtual environment? The other servers I have are;
64 bit Win2k8 R2 Std
8GB ram
3.10 GHz Quad Core Xeon
2 x 500GB HDs
Mainly used as a terminal server
32 bit Win2k8
4GB ram
2.4GHz Dual Core Pentium
160GB HD
mainly used as a BDC
Any other way I can pull some files off the back up drive to another server?
0
 
pgm554Commented:
Once you finish the chkdsk ,I would run a diag on that disk.
I know this is Monday morning quarterbacking ,but there a reason you rotate backups using at least two different devices.
I use a 3rd party backup and run a verify at least once a week.
0
 
gromackAuthor Commented:
Diag from what?
If it matters, I ran all the Dell diagnostics & everything came back fine.
I had a system to swap disks (Seagate 1.5 TB USB drives) out weekly, but someone in the office (I'm not here full time), hasn't been doing it. I've decided to bite the bullet & use Microsoft's pay-per support option. I've got to a state where we can limp along for the rest of the day, plus I'm on my 24th hour of being here & need a nap! Besides all that, I'd imagine MS would want to run chkdsk, & I'm going to wait it out, after 5 & a half hours.
0
 
pgm554Commented:
Seagate has their own diagnostics to see if their disk is bad.
In some circumstances ,it can actually fix a bad spot on the drive.

Any other way I can pull some files off the back up drive to another server?
You could try to mount the vhd in a hypervisor.

http://www.r1soft.com/free-tool-hyper-v-vhd-explorer
0
 
gromackAuthor Commented:
stupid question time, if I pull drive out to see brand, it's not gonna want to resync when I boot up, will it?
Second, how do I get a VHD from my external drive?
0
 
pgm554Commented:
You said it was a Seagate ,so I'm assuming that's what's inside.
The backup format used by Win2008 is just a vhd ,and the entire disk is allocated as such.

http://blogs.technet.com/b/11/archive/2008/08/16/mounting-backup-file-created-by-windows-2008-server.aspx

f I pull drive out to see brand, it's not gonna want to resync when I boot up, will it?
It's just a drive that allocated as a vhd,you can't boot it.
0
 
gromackAuthor Commented:
Ok, 24 hrs later & chkdsk is still at the 12% point in verifying free space, at 1596755 of 86962720 free clusters processed...
0
 
gromackAuthor Commented:
Thanks to everyone for your help! I came back in this morning, chkdsk was still on stage 5 of 5, verifying blank space, in the exact same spot I left it nearly 24 hours earlier. Restore would still not complete successfully, After that one failed, I didn't reboot, but went back to the backup from the day before that, attempted another restore. This started off slow & took a lot longer than other attempts & after a little over two hours (previous attempts only took 20-30 minutes), it finally came back with 'The backup is restored' message, I rebooted server & am happy to say, all is well! I am curious why my latest BU may not have worked. No errors in log file, only thing I noticed was it started about 10 minutes later thsan scheduled. Also, other than actually restoring, how can I verify my backups are good & useable in the future? Thanks again for all your help!
0
 
David Johnson, CD, MVPOwnerCommented:
CHKDSK should not have taken that long.. something is amiss in your disk subsystem. Were you doing a chkdsk /f or chkdsk /f /r (I never use the /r as in my thinking if a sector is bad it is bad and I don't want to re-use it)
0
 
gromackAuthor Commented:
Jeeez!
I had read cases where people had it run for days, although not sure of their particular scenarios. It was with the /r switch, IIRC & the Dell tech I was working with recommended that, but initially the Dell diagnostics (long version) showed no problems with anything. Drives were recommended for that server by Dell & are only 6 - 7 months old. Right now things are running fine & I have good backups. As far as checking into the possibility of other problems, what do you suggest?
0
 
pgm554Commented:
My take is to run the disk manufacturer tools.
Seatools has fixed quite a few issues for me in the past when the built in chkdsk could not.
See attached from Seagate
seatools.PNG
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

  • 8
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now