Exchange 2010 SBS2011 Cant open EMC

Error message when I try to start Exchange Management Shell (EMS) or Exchange Management Console (EMC): "The WinRM client... cannot determine the content type of the HTTP response from the destination computer"

I have researched this for 2 days now and need some help.
Computer HelperWindows Server AdminAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David AtkinTechnical DirectorCommented:
Restart the World Wide Publishing Service and IIS.

Do you get the same error?  

Check in IIS Manager to see if there are any application pools that are stopped.
Manikandan NarayanswamySecurity Specialist & IBM Security GuardiumCommented:
Hi,

Refer the below KB article for the resolution for this error.

https://support.microsoft.com/en-us/kb/2028305

Thanks
Manikandan
Manikandan NarayanswamySecurity Specialist & IBM Security GuardiumCommented:
Hi,

You can try the thread which is been resolved on expert-exchange previously.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_27899132.html

Thanks
Manikandan
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Computer HelperWindows Server AdminAuthor Commented:
Thanks for all of this. It still has not resolved the error, though.
What I've done:
Restart WWPS and IIS.
Verified correct settings for Kerberos and Default Web.
Checked the WSMan module in AppHost.config file.
Removed and Re-added WinRM.

Yesterday, exchange in building was broken. Fixed exchange by installing updates and rebooting. Performed SFC and CHKDSK overnight. Tried to log in this morning and get User Profile Failed the... Cannot load the profile. Logged into secondary admin account. Performed IIS Reset with copy of {C:\inetpub\wwwroot} from another SBS 2011 server. Still no luck. Reran EMTshooter and get error message that user account is not enabled for Remote Powershell.
Fixed primary admin account by going to the HKLM\...\Profilelist

Unable to connect in primary account. EMTshooter gives me the same suggestions.

Any ideas?
David AtkinTechnical DirectorCommented:
Can you open the EMC in another Admin Account?

Have a quick read of this article to see if any of the steps help you.

When you say Exchange was broken, what was the issue?

Are you trying to open the EMC from the SBS or another server?

Copying the  wwwroot folder may have been counter productive if its a slightly different version etc.  Did this solve any errors?  If not, I would set it back to the original.
Manikandan NarayanswamySecurity Specialist & IBM Security GuardiumCommented:
Hi,

My Suggestion would be Create a new Administrator account add the user too the member off > EnterPrise Admin, Schema Admin, Domain Admin, along with Exchange Organization Management and IIS_User group and see if it works

Thanks
Manikandan
Computer HelperWindows Server AdminAuthor Commented:
@David
1. I cannot open EMC in another admin account.
2. Unable to read article, no link.
3. No clients inside able to get email, would prompt for password and kick out. Again, emails are being delivered currently, just can't login to EMC.
4. Attempting to connect to EMC via SBS. No other servers in company.
5. IISReset did not solve any issues, per your advice, reset back to original.

@Manikandan
Secondary admin was created new this morning with member of all listed above.
Manikandan NarayanswamySecurity Specialist & IBM Security GuardiumCommented:
Hi,

Exit the EMC > Windows Key +R > cmd {Enter}
Execute the followig two commands;

DEL "%USERPROFILE%\AppData\Roaming\Microsoft\MMCDEL "%USERPROFILE%\AppData\Roaming\Microsoft\MMC\Exchange Management Console.*"

REG DELETE HKEY_CURRENT_USER\Software\Microsoft\ExchangeServer\v14\AdminTools /v NodeStructureSettings /f

Also find the below screenshot and try the same. This resolved my issue 3 days back

Thanks
ManikandanCapture
Computer HelperWindows Server AdminAuthor Commented:
When opening EMS I get this error

VERBOSE: Connecting to AAASPHALTSERVER.wepaveit.local
[aaasphaltserver.wepaveit.local] Connecting to remote server failed with the following error message : The WinRM client
 cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. T
he content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
   eption
    + FullyQualifiedErrorId : PSSessionOpenFailed
VERBOSE: Connecting to AAASPHALTSERVER.wepaveit.local
[aaasphaltserver.wepaveit.local] Connecting to remote server failed with the following error message : The WinRM client
 cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. T
he content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
   eption
    + FullyQualifiedErrorId : PSSessionOpenFailed
VERBOSE: Connecting to AAASPHALTSERVER.wepaveit.local
[aaasphaltserver.wepaveit.local] Connecting to remote server failed with the following error message : The WinRM client
 cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. T
he content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
   eption
    + FullyQualifiedErrorId : PSSessionOpenFailed
Manikandan NarayanswamySecurity Specialist & IBM Security GuardiumCommented:
Hi,

You have to do this on Windows Powershell.

Thanks
Manikandan
Manikandan NarayanswamySecurity Specialist & IBM Security GuardiumCommented:
Hi,

Or simply add the parameter mentioned on the screenshot on the file. Restart IIS services and check.

Thanks
Manikandan
Computer HelperWindows Server AdminAuthor Commented:
I think I got it.

I did this and it worked.

Your error is specifically to do with 'client impersonation'. I had the same error on one machine but not on another. By comparing settings I worked out the difference.

Start IIS Manager. Select the server in the left pane and double click 'Authentication' under the IIS group in the central pane. Select ASP.NET Impersonation and select 'Disable' at the top of the right pane.

http://stackoverflow.com/questions/14445252/http-error-500-24-internal-server-error-an-asp-net-setting-has-been-detected-t

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Computer HelperWindows Server AdminAuthor Commented:
I got it.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.