Windows Server 2012 wont create a failover cluster due to SCSI page 83h VPD descriptor when validating an iSCSI target on a Ubuntu 14.04 server

I am trying to create a Windows Server 2012 R2 fail over cluster with an iSCSI drive located on a Ubuntu 14.04 server. The Servers both connect to the Ubuntu target beautifully, but when I go to validate the fail over cluster I get the following error which fails the cluster creation: "Physical disk {2ed5a1cd-5f82-463b-95b7-a08f3151a168} does not have the inquiry data
(SCSI page 83h VPD descriptor) that is required by failover clustering."

This means that the SCSI page 83h VPD descriptor value is not being sent when Windows queries the Ubuntu server on the iSCSI specifications (better described here: http://linhost.info/2012/05/configure-ubuntu-to-serve-as-an-iscsi-target). After researching Ubunutu on how to set the SCSI page 83h VPD descriptor i found these two man pages: http://manpages.ubuntu.com/manpages/dapper/man8/scsi_id.8.html and http://manpages.ubuntu.com/manpages/hardy/man8/scsi_id.8.html . The command I come up with is 'sudo /lib/udev/scsi_id --page=0x83 --device=/dev/sda2', however when executed the SCSI page 83h VPD descriptor is not echo'd nor does the error go away when creating the cluster, which I take to mean that Im not executing the command correctly. I believe what is wrong is the device attribute... I dont believe that is correct, and I'm not sure on the correct syntax. Ultimately all I want is to create this cluster, so if theres some way to set the descriptor (say in the iSCSI target creation conf file) other than this command then awesome please let me know what that is... If theres a way to disable this check on Windows then great let me know what that is. Any help would be greatly appreciated!

Thanks!
LVL 4
Nathan HawkinsTechnical Lead - Network SecurityAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kevinhsiehCommented:
This is most likely an issue with SCSI-3 persistent reservations. I don't know which specific target software you are using. You can check bout these two links for pointers.

http://linux-iscsi.org/wiki/Persistent_Reservations

https://smurariu.wordpress.com/2012/06/07/configure-iscsi-3-target-persistent-reservation/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Nathan HawkinsTechnical Lead - Network SecurityAuthor Commented:
I used http://linhost.info/2012/05/configure-ubuntu-to-serve-as-an-iscsi-target/ as a guide to setting up an iSCSI target. Lio eh? Well it looks like the thing to use! Loading it up now.
Nathan HawkinsTechnical Lead - Network SecurityAuthor Commented:
Ok, I agree this is the direction I need to go, but the commands arent lining up... The directions from the first link suggest:

/etc/init.d/target start
tcm_node –block iblock_0/my_iblock0 /dev/sdb
lio_node –addlun iscsi-test 1 1 lun_my_block iblock_0/my_iblock0
lio_node –addnp iscsi-test 1 10.0.0.1:3260
lio_node –disableauth iscsi-test 1
lio_node –enableaclmode iscsi-test 1
lio_node –addlunacl iscsi-test 1 iqn.1998-01.com.vmware:vlvstest02-4b466a50 1 1
lio_node –enabletpg iscsi-test 1
tcm_dump –t 2011-09-22_BASE
lio_dump –t 2011-09-22_BASE
tcm_dump –o

What I have and have done so far:
/dev/sda is the LSI 9261-8i RAID card I have. sda2 is a 2TB partition where I want the storage to be setup at. The way I set it up originally is through a file which will grow to 50g called server.img. I mounted the partition to /iscsi and the file is located at /iscsi/server.img

The config for the target which works, but doesnt give the 83h page descriptor Microsoft is looking for is:

sudo dd if=/dev/sda2 of=/iscsi/server.img count=0 obs=1 seek=50G

then under /etc/iet/ietd.conf
Target iqn.2015-04.domain.com:storage.sys0
Lun 0 Path=/iscsi/server.img,Type=fileio,ScsiId=lun0,ScsiSN=lun0

With the above when I search for the target with Microsoft it sees the target just fine, attaches and I can format the drive.

The part with the LIO setup that isnt aligning is I need to set up the partition sda2 not the whole raid array sda, further its really with the file that will be the actual storage point.

The config at the link you had sent seems to create a target not on the raid array, but on the disk/partition where all of my system files are located.

So how do I set up LIO to create an iSCSI target on /dev/sda2 ?
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

kevinhsiehCommented:
I have never tried iSCSI target in Linux, always through a commercial SAN or Windows target. Sorry I don't know if I can be more helpful.
Nathan HawkinsTechnical Lead - Network SecurityAuthor Commented:
Naw man - You nailed it! So... theres different modes you can setup for iSCSI. The mode I want is called fileio. Now knowing what it is I want I was able to search for that and found this awesome link:

http://www.linuxclustering.net/2012/11/08/step-by-step-how-to-set-up-a-low-cost-san-with-the-linux-software-iscsi-target/

Which walked me all the way through setting up EXACTLY what I was asking for. Yes I had to do a fair amount of leg work but essentially you not only answered the question, you solved the problem. Great stuffs and MANY thanks!
success.jpg
kevinhsiehCommented:
Glad to have been able to point you in the right direction.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.