HP Laserjet P3015 paper type

I have a HP Laserjet P3015 Laserjet Printer. The hardware on the printer is set so it uses the "plain" paper type. When you log into the machine (PC) though it keeps switching from "color" to "unspecified" without the user initiating the change. I have tried changing the drivers and this doesnt work. Does anyone have an idea as to what might be causing the issue? Thanks in advance for any help!
RVFB ITAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dr. KlahnPrincipal Software EngineerCommented:
This is typical behavior under Windows, in my own experience.  When logging into a system the printer parameters go back to the defaults.

I suspect this is a deliberate policy decision by Microsoft so that one user does not get another user's possibly-unwanted printer settings.

I've never found this so annoying that it was worth figuring out how to make the settings permanent, but a bit of research turned up this suggestion:

Once you get to the printer in the Printers section under Control Panel, right click on it, set & save your color settings under both the Printing Preferences and Properties section. See if that takes care of it. You often have to set your preferences in both sections for it to stay.

Any settings that can not be changed through Printing Preferences or Properties are probably part of the HP support software and it's probable that there is no way to save those.
Spike99On-Site IT TechnicianCommented:
I think you might need to change the setting under "Printing Defaults" not printing "Preferences..."  You would need to do this with administrative rights on the PC or server in question because this will change settings for all users.

To get to that:
1.  Right-click on the printer
2.  Click on "Printer Properties"
3.  Click on the "Advanced" tab
4.  Click on the "Printing Defaults..." button
5.  Change the paper type settings & save your changes

The "Preferences" button on the General tab will only change that user's preferences for using that printer. The "Printing Defaults" button will change the default behavior for everyone who uses that printer.

That being said, sometimes printer settings won't "stick" even after an administrator has changed the printing defaults.  In most cases, that's caused by an issue with the driver.  So, please make sure you are using the latest driver for that printer.

You didn't specify the OS for this computer, but you can download HP drivers on this page (specific Windows 7 & 8 drivers don't appear to be available for this printer, you'd have to download HP's universal print driver): http://h20564.www2.hp.com/hpsc/swd/public/readIndex?sp4ts.oid=3815808

You can also download P3015 drivers designed specifically for Windows 8/8.1 from the Windows Update Catalog page (you must use IE to access the downloads on this page):
https://catalog.update.microsoft.com/v7/site/Search.aspx?q=laserjet%20p3015

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.