Problem Running adprep /forestprep from automated 2012 DCPROMO and manually

Wondering if anyone had any advice for me.
I have 2 Server 2003 SP2 machines right now, one holds all 5 roles and the other is a backup.  They are on the same LAN.  Functional level is 2003.

I'm adding 2 more DC's and demoting these two.  The new ones are 2012r2.
I installed the ADDS role on the first new proposed domain controller.  The first time I ran DCPROMO from the server manager it took a bit to run and finally failed out complaining about a system connected to the machine was not functioning during the initial forestprep.  After reading the logs its apparently an access denied error that it can't contact whichever server I have as the schema master.  Since running adprep /forestprep since then, both from server manager and the disk, it fails immediately with the same error each time on trying to create the same object in the schema, I can look up the GUID if need be.

I'm not sure which permissions I'm missing, I am every type of administrator out there and local admin on the machines.
I also get this running a DCDIAG.

 The File Replication Service SYSVOL ready test
         The registry lookup failed to determine the state of the SYSVOL.  The

         error returned  was 0x5 "Access is denied.".  Check the FRS event log

         to see if the SYSVOL has successfully been shared.

However, SYSVOL and NETLOGON are there, shared and healthy (replicating).
Another problem is when I look up the schema version it is 69, meaning 2012r2, so it looks like it already upgraded the version number, but not all of the schema.  However, I can't add a 2012r2 DC without doing a forestprep first.  And I wasn't sure if I should try to run a 2008r2 forestprep since it thinks it's already 2012r2.  Would that hurt anything?
Any help would be really great.
Mike JonesIT AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike JonesIT AdministratorAuthor Commented:
For anyone that has this problem and stumbles across this article, this got it going for me, finally.

To those who still have a problem after fixing the remote registry and ISA connections, try this:http://technet.microsoft.com/en-us/library/bb847900%28v=exchg.80%29.aspx

This is what finally got it working for me..
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Thomas GrassiSystems AdministratorCommented:
Glad to see you got it working

I am planning to upgrade from 2003 to 2013 also

Will add this to my notes and planning stages
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.