Website,DNS or Proxy issue

I have a question regarding a website that is hosted on our server. Website works just fine. All users that need internet access have to go through a proxy. All our internal websites are put into the proxy exclusion list so users are not prompted for their credentials. The problem we have is the website has a dash in the link and it can't be added to the proxy exclusion. The proxy is setup on a 2012 server and is pushed through a GPO. Whenever you try to add the dash, everything behind it moves to the next line. Is there a fix for this other than changing the website and re-registering?

Thanks,
Mike
aintgot1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Codrut TambuSr. Software Developer EngineerCommented:
what proxy engine you use?
check documentation for character escaping.
you should escape the dash or try using regular expression if supported.
0
aintgot1Author Commented:
Not sure what you mean by proxy engine. Is this a configuration setting on the proxy server? Unfortunately I don't have access but could find out next week. Where we are getting this error so to speak is in the GPO where we specify what websites can pass through the proxy without being prompted for credentials.

Thanks,
Mike
0
Codrut TambuSr. Software Developer EngineerCommented:
I mainly use semicolon separated lists with Win2012 proxy and GPO, like:
"ProxyOverride"="http://*.internal.lan;https://*.another-internal.com;<local

Open in new window

Have you checked these resources:
https://technet.microsoft.com/en-us/library/cc754834.aspx
https://technet.microsoft.com/en-us/library/dd361953.aspx
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

aintgot1Author Commented:
I couldn't find anything in those resources that addressed my issue. In your example, your https://*.another-internal.com is where I'm having the issue. If I typed it that way, it would look like this.

https://*.another-
internal.com

Everything behind that dash would move to the following line even if it was the first entry on that line.



Thanks,
Mike
0
Frans BrouwerSenior Systems AdministratorCommented:
try instead of - to use %2d
0
Codrut TambuSr. Software Developer EngineerCommented:
Where do you enter the GPO in Active Directory?
Can you send me a print-screen with your GPO screen?
Usually you have different alternatives for character escaping based on the interface. I always used semi-colon(;) separated values so no matter it contains special characters it splits the entries by semicolon (;) like in the IE proxy settings.

But otherwise, try escaping the dash.
It's all up to the escaping capabilities of your policies processor.
Try escaping with \ (back-slash); like: http://www.another\-internal.com

Or, as Frans also mentioned you could try escaping with
url-encoding alternative like %2d
resulting => http://www.another%2dinternal.com

or the html-encoding escape alternatives:
&#045; &hyphen; or &dash; or &mdash;
resulting => resulting => http://www.another‐dinternal.com
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aintgot1Author Commented:
I'll see if I can get a print screen today sometime and I'll also try the other escape alternatives as well. If I can't get them today I'll post tomorrow.


Thanks,
Mike
0
aintgot1Author Commented:
Sorry about the delay for the update. It seems that my original question needs to be updated as well. I was able to add a website to the proxy exception list but the current problem is that once you go to that site the proxy authentication box will pop up. If you hit ok or try to close it, it will continue to prompt. If you hit cancel, it will go away and let you on the website. Everything I tried that was suggested didn't work, mostly because it was for a different reason. So, at this point I would like to find out why the user gets prompted for the proxy and is then allowed to go through after hitting cancel.


Thanks,
Mike
0
Frans BrouwerSenior Systems AdministratorCommented:
normally it would prompt you once everytime you use the proxy. it depends how your config of your proxy is - can you check these settings?

I assume you are using Microsoft proxy or not?
0
Frans BrouwerSenior Systems AdministratorCommented:
btw if you managed to get the right url in the proxyoverride option maybe it cannot read the right url? ie the rule does not apply?
0
aintgot1Author Commented:
We have a separate proxy box and I don't have access to it. I would have to ask to see if there is a setting that may cause this. I do not believe this is a Microsoft proxy, but a third party software.

I'm not sure if I understand your second response. When I tried the character escaping, I would get page can't be displayed. When I put the correct URL in, I would get prompted for proxy credentials but could get through by hitting cancel. Maybe I should have the proxy settings looked at instead of proxy exceptions in GPO?


Thanks,
Mike
0
Frans BrouwerSenior Systems AdministratorCommented:
oke just to be sure :

1: every local browser gets the proxy parameters pushed via Group Policies
2: every local website is put in override parameters considered as local sites and therefore bypasses proxy all together.
3: the proxyserver is a blackbox - squid ? on linux ?

with all these open ends we need more information.

regards ,
0
aintgot1Author Commented:
1: Yes
2: Yes
3: From what I have been told, the proxy boxes are computers with Windows 2003 server and the proxy software is a 16 bit software that has been modified.


Thanks,
Mike
0
Frans BrouwerSenior Systems AdministratorCommented:
Please check on client if configuration in browser proxy setting contains the right url as local bypassed
0
aintgot1Author Commented:
Been pretty busy and had to put this aside. The partial update so far is another GPO was created with the proxy settings for this one particular website in question with the dash in the URL. It was link to a OU with no other GPO's linked to it. There are other GPO's that restrict users from accessing some browser settings, which is why the additional GPO. I was able to open the website without being prompted for proxy credentials. Now, this was done at a site that is running 2008 R2. With time permitting, I will try this on another site running 2012 and see what the results are.


Thanks,
Mike
0
aintgot1Author Commented:
Thanks for your input on this question. At this point they are content on just hitting the cancel to pass through to the website.  


Thanks,
Mike
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.