How can I resolve VERY poor network transfer rates on a Hyper-V VM?

Hi everyone,

I have a Hyper-V host and 2 VMs. My host can transfer data between a backup server and itself between 80 - 100 MB/s (yes, megabytes per second)

The two VMs can transfer no faster than 2 MB/s, and typically average 0.4 MB/s. There's got to be something configured incorrectly, but I wouldn't know where to begin. Suggestions?
LVL 4
ITworksAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MikeIT ManagerCommented:
Look at the Virtual Switch settings inside of Hyper-V to make sure it isn't throttling the connection.
0
learn_itCommented:
Hi,

You may want to go into the  NIC properties on the host, select ADVANCED tab and disable VIRTUAL MACHINE QUEUE setting.
This worked for our Server 2012 R2 deployment. We experienced similar issues.

Also, be sure to check "Enable Virtual Machine Queue" setting in the property of each Hyper V machine  and disable it as well.

Thanks!
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Broadcom NICs on the physical host? If yes, then disable VMQ (Virtual Machine Queues) for EACH physical network port listed in NCPA.CPL.

I suggest a reboot but it may not be immediately necessary.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ITworksAuthor Commented:
Broadcom NICs. I updated to the latest driver from Broadcom's site. I disabled VMQ. I changed Jumbo Frame rate to 4088. I disabled the TCP Offload (can't remember it's exact name).

It went from 0.3 -- 0.5 MB/s to 5.8 MB/s - 6.2 MB/s. Exponential increase! However, still a ways off. The Hyper-V Host is a brand new R320 with Gigabit NICs. The switch is a Netgear 10/100/1000 switch. The Hyper-V Host can transfer data to and from the backup appliance between 80 MB/s - 100 MB/s, so the fact that the VMs are only getting roughly 6 MB/s transferring data to and from the exact same backup appliance tells me that it's got to be a software setting somewhere.

I hope this helps.
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Reset your Jumbo Frames back to Default on _all_ connected devices and NICs. This is probably the one that's biting.

Reset any other networking stack changes.

Reboot everything and try again.
0
ITworksAuthor Commented:
All of these suggestions helped and now we're running perfectly! Thanks guys!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hyper-V

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.