On-premise Exchange server interfering with Office 365 Mail

I recently setup Office 365 mail on my network and to do away with our onpremise Exchange server. I changed the MX and CNAME records to port to Office 365 but when I setup the users 365 email on Outlook it doesn't autodiscover and I keep getting the login pop-up. I also removed the mail and autodiscover DNS records on the onpremise server. Do I have to disable anything on the Exchange 2010 server?
csciarroAsked:
Who is Participating?
 
Vasil Michev (MVP)Commented:
Did you disable the SCP? Easy way to solve this issue is to 'instruct' Outlook to bypass the local server discovery by using the registry keys in this article: http://support.microsoft.com/kb/2212902

All you need for EO/O365 is the HTTP redirect method to work, you can block all else. And this doesnt require you messing with the local infrastructure in any other way.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.