Exchange 2010 DAG not working the way it should

We were under the impression that we had an Exchange 2010 DAG.  I believe that we have a DAG, but it isn't working properly, so is it really a DAG?

Anyhow, i digress.

I recently noticed that log files weren't truncating after backup (Windows Server Backup) and that the Exchange Mailbox directory on our main Exchange db VM was getting very large.  So large in fact that yesterday the VM starting pausing every 3 minutes or so.

I have attempted moving a bunch of logfiles to a different network location, but as the VM kept pausing I wasn't able to get many moved and then it blue screened on me so I laid off.

At this point the database and log files together total over 550GB of data.  At this point we are not receiving any email because that VM is offline.  

I see a copy of that database on the failover DAG member, but for some reason it did not pickup.

I am in the process of exporting the VM to another larger hard drive, but it's taken over 12 hours and it's still nowhere close to finishing.

Hyper-V physical host is running Server 2008 R2 x64.  VMs are all running the same.  Exchange is 2010 and not patched up to date w/ SPs.

HELP!!
dchewAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MikeIT ManagerCommented:
The fact the log files aren't automatically deleting tells us that either your backups are locking the files so they cannot be deleted, or that your DAG is not working properly.  

What happens when you try to mount your mail stores on your backup server?
0
dchewAuthor Commented:
OK 2 Mailbox Store servers.  X3 and X4

X3 is the one that filled up the RAID container and has been pausing; and currently shut down.

I am unable to mount on X4 because X3 is offline.
0
MikeIT ManagerCommented:
Your DAG is severely messed up, then.  The whole point of a DAG is to be able to function if one server is offline.

Can you not load X3 at all?  Also, I hope you don't have your DBs installed on the C: Drive.
0
Simon Butler (Sembee)ConsultantCommented:
Run

get-mailboxdatabasecopystatus on all three servers. That will tell you whether you have a correctly functioning DAG. I expect not.

If they are in the same site, what I would do is remove the servers from the DAG so you are down to individual servers. On the server with the mounted database do an Exchange aware backup to flush the logs. If that will not work, then enable circular logging to flush the logs, then disable it again and do an Exchange aware backup.

If the servers are not fully patched, then I would bring the two other servers up to date with service packs and rollups. Then on them create a new DAG and a new database. Move all users in to the new database (slowly, to allow replication to take place). Once you have everyone on to the new servers, patch the last one and add it to the DAG.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.