Secure connection to web interface of the router from VM on HYPERV 2012 R2 does not work.

I have just build a HYPERV host server using MS Server 2012 R2 Standard and installed 2 VM's on it.

I am unable to connect to secure web interface of the router (Cisco RV042.) from those VM's.

I can connect fine to the interface from any "hardware" machine, but when trying to connect from the VMs (one VM is server 2012 R2 standard, other VM is win 7 Pro) it fails to connect. I have no issues pinging the gateway or browse the internet from VMs.
I tried to modify the the Virtual Switch settings - tried different NICs and different ports on the HUB, cleared cache of the browsers (tested with Chrome and IE 11) removed and readded the virtual NICs - it does not work.
I have very similar (The router is Cisco SA520 instead of RV042) setup at another location and it is not a problem there.

Any thoughts?
LVL 1
pyotrekAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joshua HopkinsPresidentCommented:
Make sure that the vm ip is allowed to access the web interface.
pyotrekAuthor Commented:
I have not limited access to the web interface to specific IP's. I have been connecting from "hardware" PCs with random internal IPs just fine - it does not seems to work only from VMs.
Joshua HopkinsPresidentCommented:
Are the vm machines on the same subnet?
SolarWinds® VoIP and Network Quality Manager(VNQM)

WAN and VoIP monitoring tools that can help with troubleshooting via an intuitive web interface. Review quality of service data, including jitter, latency, packet loss, and MOS. Troubleshoot call performance and correlate call issues with WAN performance for Cisco and Avaya calls

Joshua HopkinsPresidentCommented:
You can also try to specifically add the IP for the vm.
pyotrekAuthor Commented:
It turned out to be the issue with the driver - after changing the NIC driver to driver provided by manufacturer the issue is gone.

Please close the question.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pyotrekAuthor Commented:
Please do not assign points - just close the question - resolved myself (see my previous comment)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.