We help IT Professionals succeed at work.
Get Started

Having trouble setting persistant status DHCP address

Mark
Mark asked
on
383 Views
Last Modified: 2015-04-21
I am running dhcpd 4.2.5-P1 and bind 9.9.5-P1 on Slackware64 14.1, kernel 3.10.17. So far, I've successfully set up 14 LAN hosts (mix of Windows workstations, Linux hosts and devices like postage meter) with assigned DHCP addresses of the following form in /etc/dhcpd.conf:
# Web Server (Linux)
host webserver {
    hardware ethernet 60:A4:4C:61:9C:FE;
    fixed-address 192.168.0.3;
}

:
:

# Security Video
host dvr {
    hardware ethernet 00:12:12:8A:4C:33;
    fixed-address 192.168.0.24;
}

Open in new window

All of these work, most for several months now, except the one shown at bottom above which I configured this afternoon: 'host dvr'. This is a video/DVR device. I've tried everything I can think of. I've restarted both dhcpd and named several times. I see odd messages in the dhcpd.log:
Apr 20 16:14:43 mail dhcpd: DHCPOFFER on 192.168.0.24 to 00:12:12:8a:4c:33 via eth1
Apr 20 16:14:43 mail dhcpd: DHCPREQUEST for 192.168.0.24 (192.168.0.2) from 00:12:12:8a:4c:33 via eth1
Apr 20 16:14:44 mail dhcpd: DHCPACK on 192.168.0.24 to 00:12:12:8a:4c:33 via eth1
Apr 20 16:14:44 mail dhcpd: Added new forward map from LocalHost.hprs.local. to 192.168.0.24

Open in new window

The other hosts' log messages have their assigned hostname, e.g. WEBSERVER.hprs.local, whereas this host shows in the log with LocalHost.hprs.local. Why?

I cannot resolve host dvr, but I can resolve host LocalHost.hprs.local:
$  host dvr.hprs.local
Host dvr.hprs.local not found: 3(NXDOMAIN)

$ host LocalHost.hprs.local
LocalHost.hprs.local has address 192.168.0.24

Open in new window


nmap show I am talking the the DVR device, and do have the correct MAC address. I can pull up the device's web page at http://192.168.0.24
$ nmap -T4 -A 192.168.0.24
Nmap scan report for LocalHost.hprs.local (192.168.0.24)
|_http-title: NETSurveillance WEB
:
|_  OPTIONS, DESCRIBE, SETUP, TEARDOWN, GET_PARAMETER, PLAY, PAUSE
:
MAC Address: 00:12:12:8A:4C:33 (Plus )

Open in new window

Even nmap returns LocalHost.hprs.local as the FDQN!

I find no place in the DVR device network setting where a host name of LocalHost is specified. The DVR is set for DHCP. Obviously, LocalHost cannot be used to refer to this device throughout the LAN as localhost is sef-referential for each host.

Where is it coming up with the host name 'LocalHost'? Why is it not using my assigned host name 'dvr'? Can someone help me figure this out?
Comment
Watch Question
CERTIFIED EXPERT
Commented:
This problem has been solved!
Unlock 1 Answer and 4 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE