centos custom iso not booting from uefi mode

hi all please help with below issue:

i am installing my custom centos iso to dell hardware.

boot sucess with legacy but not with UEFI mode gives attached eror and hangs.

thanks
ScreenShot342.png
The RockAsked:
Who is Participating?
 
rindiCommented:
Standard BIOS allows you to access large storage. The large "disk" just has to be GPT. With Linux, contrary to m$ OS's, you can even install the OS to a GPT disk and boot to it when your BIOS isn't using UEFI mode, even though I don't recommend that. It is better to install the OS to a small disk and then have a separate large disk for the data. It makes backup and management easier.
0
 
StolsieCommented:
You will have to turn off UEFI in the BIOS, i had to do it for my flavors
http://www.pcmag.com/article2/0,2817,2417361,00.asp
0
 
Zephyr ICTCloud ArchitectCommented:
How did you create the ISO, did you copy all necessary files to your disk? What's you media, CD or USB?
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
The RockAuthor Commented:
Actually it is working when i am instaling a raw image but its failing when i am installing with my own custom image using kickstart
0
 
The RockAuthor Commented:
Yes all files are placed correctly including EFI directorey
0
 
The RockAuthor Commented:
my custom iso work correctly with leagcy bios mode
0
 
Seth SimmonsSr. Systems AdministratorCommented:
have you tried the original media?
mount that iso UEFI and see if it boots correctly
if it does, then there is an issue with your custom media
0
 
Zephyr ICTCloud ArchitectCommented:
Are you trying to boot via USB media?
0
 
rindiCommented:
Is there any reason you need to boot into UEFI mode? Personally I can't think of any good reason to do so, even if I waste hours and hours trying to find a reason. Just change your BIOS to legacy mode and it should work fine.
0
 
The RockAuthor Commented:
Hi yes i know some issue is there with custom iso but same i want to know how to resolve it.

actually uefi mode have larger storage capacity from HP gen 9 servers other wise it wont be able to use whole capability of hardware
0
 
The RockAuthor Commented:
Also could you help me how to deal or go with GPT enabled disk and what entries need to done in kickstart cfg file ? might be that could be a issue because i am using kickstart file for installation in custom iso
0
 
The RockAuthor Commented:
Have a look at below article and advice:
http://www.cyberciti.biz/tips/fdisk-unable-to-create-partition-greater-2tb.html

if i can create GPT parttion layout in my  kickstart config so that it could suport EFI boot?

for now i am using below parttion lay out:

## Partion Declaration

part /boot --fstype=ext4 --size=256
part pv.008226 --size=25600
part pv.008227 --size=15360
 
volgroup vg_infra --pesize=4096 pv.008227
logvol /images --fstype=ext4 --name=lv_images --vgname=vg_infra --size=4096
volgroup vg_root --pesize=4096 pv.008226
logvol /home --fstype=ext4 --name=lv_home --vgname=vg_root --size=1024
logvol /opt --fstype=ext4 --name=lv_opt --vgname=vg_root --size=512
logvol / --fstype=ext4 --name=lv_root --vgname=vg_root --size=3072
logvol swap --name=lv_swap --vgname=vg_root --size=2048
logvol /system --fstype=ext4 --name=lv_system --vgname=vg_root --size=128
logvol /tmp --fstype=ext4 --name=lv_tmp --vgname=vg_root --size=2048
logvol /usr --fstype=ext4 --name=lv_usr --vgname=vg_root --size=4096
logvol /var --fstype=ext4 --name=lv_var --vgname=vg_root --size=6144

Open in new window

0
 
gheistCommented:
You must use some UEFI system to import and trust your signature that you apply to boot file on DVD.
Or disable UEFI secuirty altogether.
0
 
The RockAuthor Commented:
ok thanks Gheist and rindi - one small query
## Partion Declaration

part /boot --fstype=ext4 --size=256
part pv.008226 --size=25600
part pv.008227 --size=15360
 

Open in new window


in above code i want to configure pv in such a way so that 1 pv take fix size and 2 pv took rest of the disk size for ex.

disk size = 100 gb

pv1 i define 20 the pv2 automatically select 80 gb because i want to make it feasible with diff size of disks.

thanks
0
 
gheistCommented:
You need 100MB /boot/efi
500MB /boot
Some swap
Some 20-50GB /
Rest at your choice

namely /boot must be separate so you can recover from broken /
0
 
rindiCommented:
If you have disabled UEFI mode as I recommended, you don't need an EFI partition. It also isn't absolutely necessary to have a separate /boot partition. It is usually enough to have a / partition for the OS, a Swap partition, and maybe a separate /home partition for user profiles and data.
0
 
gheistCommented:
You dont have to disable UEFI completely, just secure boot - image signature check...
You will thank me later for separate /boot partition.
0
 
The RockAuthor Commented:
thank you i got it but above i am asking something diffrent - i need to know the exact syntax of defining PV's in my kicstart file like i need 2 PV and want 1 PV of 20GB and second PV should take rest of the size of disk

please help?
0
 
gheistCommented:
Initial question was about and around UEFI boot rejecting your CD image...
0
 
rindiCommented:
Agreed, open a new question for that.
0
 
The RockAuthor Commented:
Okay thanks :)

done :

this is the new one:  http://www.experts-exchange.com/OS/Linux/Q_28664557.html
0
 
The RockAuthor Commented:
Thanks to both :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.