Cannot connect shared storage to VMWare EXSi 5.5 host without formatting

Client has two ESXi 5.5 hosts. Each host has its own local storage. They also have two iSCSI servers that act as shared storage.

Host2 has both of the shared storage servers connected in Storage Adaptors and under Storage. I can see the Datastores and all works fine.

Host1 used to be able to see both shared storage servers but after a recent power blip (which caused Host1 to reboot)  it cant see the Datastore . It can connect to the iSCSI target no problem but when I try to add under Storage I can only add by format the datastore - which is not going to happen as there are VMs running off of it!!

Some screen shots:
Able to see iSCSI:
1.JPGCan see the iSCSI storage when trying to add Storage:
2.JPGForced to format it:
3.JPG
Anyone got any ideas?

Thanks
Mark/
LVL 13
Mark GalvinManaging Director / Principal ConsultantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MikeIT ManagerCommented:
Have you tried unmounting that iSCSI target and re-mounting it?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
At the console or remotely via SSH, can you type the following:-

esxcfg-volume -l

paste the output back here

you should get something like

~ # esxcfg-volume -l
VMFS3 UUID/label: 4cc89503-f054d0d4-2865-00221958e471/nas3-vmfs
Can mount: Yes
Can resignature: No (the volume is being actively used)
Extent name: naa.600140588e9bab7d2b7ed4b53dadc1de:1     range: 0 - 1048319 (MB)

and then type...either

esxcfg-volume -m 4cc89503-f054d0d4-2865-00221958e471

or

esxcfg-volume -m nas3-vmfs
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mark GalvinManaging Director / Principal ConsultantAuthor Commented:
Andrew

Came back with:
"VMFS UUID/label: 5460d9c7-82e0a7f8-8bf9-0026b94773de/FNAS
Can mount: Yes
Can resignature: No (the volume is being actively used)
Extent name: t10.FreeBSD_iSCSI_Disk______002219b66311000_________________:1    range: 0 - 3814143 (MB)"

So then ran:
"esxcfg-volume -m 5460d9c7-82e0a7f8-8bf9-0026b94773de" and result was:
"Mounting volume 5460d9c7-82e0a7f8-8bf9-0026b94773de"

Worked a treat!! Thanks for that!!

Cheers
Mark/
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Excellent Result!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.