Unable to turn off Volume Shadow copies

Hi,

I have a physical windows server 2008 R2 std. that I'm using as backup repository and media server from my Data Center backup software.

so it has got 4 big NTFS LUNs presented from the directly attached HP EVA 6300 named as D, E, F and G drives respectively.

The reason I need to turn off because it was not known why this feature was turned on in the first place by my predecessor, hence I've been advised by Symantec Backup exec support team to turn this feature off because it locks the files in the drive to be written to the tape drive. Not even Windows backup can write the file to the other drive because of this issue.

See the below screenshot before it is turned off in one of the drive:
ScheduleBy defaults it is taking 2 snapshot per day.

and when I tried to delete the schedule above to turn it off completely, it always failed after the server reboot when I checked the setting again, see the screenshot below:
Error
Upon checking on the Scheduled task, somehow this tasks is always recreated after I deleted the schedule:
Automatically created
So the question is how to completely turn it off so that my Symantec Backup Exec application can backup the files in those LUNs to tape ?
LVL 9
Senior IT System EngineerIT ProfessionalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Senior IT System EngineerIT ProfessionalAuthor Commented:
Here's the event logged:

Log Name:      Microsoft-Windows-TaskScheduler/Operational
Source:        Microsoft-Windows-TaskScheduler
Date:          21/04/2015 12:53:44 PM
Event ID:      140
Task Category: Task registration updated
Level:         Information
Keywords:      
User:          SYSTEM
Computer:      BKPSRV01.domain.com
Description:
User "NT AUTHORITY\System"  updated Task Scheduler task "\ShadowCopyVolume{43593b05-ce56-4853-b03b-1b9d15d6d7c9}"

Open in new window


Log Name:      Microsoft-Windows-TaskScheduler/Operational
Source:        Microsoft-Windows-TaskScheduler
Date:          21/04/2015 12:53:40 PM
Event ID:      140
Task Category: Task registration updated
Level:         Information
Keywords:      
User:          SYSTEM
Computer:      BKPSRV01.domain.com
Description:
User "DOMAIN\Administrator"  updated Task Scheduler task "\ShadowCopyVolume{43593b05-ce56-4853-b03b-1b9d15d6d7c9}"

Open in new window


Log Name:      Microsoft-Windows-TaskScheduler/Operational
Source:        Microsoft-Windows-TaskScheduler
Date:          21/04/2015 12:53:40 PM
Event ID:      106
Task Category: Task registered
Level:         Information
Keywords:      
User:          SYSTEM
Computer:      BKPSRV01.domain.com
Description:
User "DOMAIN\Administrator"  registered Task Scheduler task "\ShadowCopyVolume{43593b05-ce56-4853-b03b-1b9d15d6d7c9}"

Open in new window


and this is the error popped up when clicking on the drive Shadow Copy service:
---------------------------
Shadow Copies
---------------------------
Failed to create a default schedule for creating shadow copies of volume E:\.
Error 0x80070050: The file exists.
---------------------------
OK   
---------------------------

Open in new window

0
Dan CraciunIT ConsultantCommented:
Have you tried disabling the "Volume Shadow Copy" service?
0
Hypercat (Deb)Commented:
You can't disable the VSS service, because Backup Exec uses it, unless you have no VSS aware applications that you are backing up (i.e., Exchange, SQL, etc.).

However, looking at you screen shots, I can see that shadow copies are disabled for all drives, and there are 0 bytes being used.  So, are you saying that just by virtue of having a task scheduled, it's locking the drive so that Backup Exec can't use it? Anyway, in order to delete the task for creating the shadow copies, you have to open the Schedule dialog box, click on the scheduled task to highlight it, and then you should see a "delete" button.  Clicking that will delete the task.  Delete all scheduled tasks and you should see "<Task not scheduled>" in that window.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Senior IT System EngineerIT ProfessionalAuthor Commented:
Ok, does disabling the volume shadow copy service can cause any impact to the current backup exec job ?

Because whenever I tried to delete the schedule it is always re-appearing in the scheduled task.
0
Hypercat (Deb)Commented:
Disabling the VSS service will impact Backup Exec if you are backing up programs such as Exchange or SQL that require VSS to be running to do an online backup.  I don't think it will have any impact if you're just doing a straight file backup.
0
Senior IT System EngineerIT ProfessionalAuthor Commented:
Well in the curent server where Backup Exec is running backup to tape, it only backs up a files that is copied over the remote DC sites, so it is not a live Excahnge or SQL database.
0
Senior IT System EngineerIT ProfessionalAuthor Commented:
ok, so the service is not supposed to be stopped right ?
0
Dan CraciunIT ConsultantCommented:
If you backup Exchange or SQL server dbs, no.

Since you only copy 1 file, you can stop the service.
0
Hypercat (Deb)Commented:
Yes - confirming what Dan Cracium said, if you're only doing file backups, you can stop the VSS service. I would set it to manual instead of disabled, unless you find that it still causes the same problem you're experiencing now.
0
Senior IT System EngineerIT ProfessionalAuthor Commented:
ok, so in this case do I just leave it running like in the following state:

Service state
0
Hypercat (Deb)Commented:
Yes, leave the service stopped and set to Manual.  Also, I would still go into the shadow copy settings and remove those scheduled items again.  I have never seen them come back like that, so I'd like you to try one more time to delete the scheduled items:

Delete shadow copy scheduled task
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.